• В этом номере:
    Истоки AUR
  • Занятные тесты WINE
  • Интервью: Travis “Cerebral” Willard
  • Некоторые сведения о грядущем инсталляторе
Newsletter for February 25, 2008
Внимание!
Пакет kernel26-2.6.24.1-2 содержит важное исправление в системе безопасности! (несанкционированное изменение прав локального пользователя).
Всем настоятельно рекомендуется обновиться.

После тестирования ядро 2.6.24.1 перемещено в Core, придя на замену версии 2.6.23.14.

Основные новшества:
  • добавлены драйвера для wireless на mac80211
  • поддержка tickless режима для x86_64
  • uvesafb; поддержка ATI Xpress 200M и Mac фреймбуферов
  • использование ACPI в libata
  • поддержка SATA port multipliers
  • поддержка NCQ на чипсетах MCP51/MCP55/MCP61(доб. ‘swncq=1’ в командную строку ядра)
  • поддержка SDIO
  • возможность использовать любую версию ядра для “пробуждения” после hibernate
  • монтирование read-only –bind
  • много других фиксов и улучшений
подробный список изменений…
Интервью с Eliott “Cactus”, новое ядро, про ext4, Yahoo и прочее…

Newsletter for February 11, 2008
  • Pacman обновлён до версии 3.1.1.
    Если обновляетесь с 3.0.х или более ранних версий обратите внимание на новую организацию списка зеркал. Теперь используется единый список для всех репозиториев /etc/pacman.d/mirrorlist.
    ABS выделена в отдельный пакет.

  • Обновлён дизайн основного сайта.
    Ну это уже наверное все заметили ;)

  • qt-4 и qt3 отправились в .
    Причём, qt версии 3 переименован в qt3, а пакет qt теперь имеет версию 4. Все возможные проблемы с зависимостями пакетов в оффициальных репозиториях на данный момент должны быть уже решены.

  • Newsletter от 21-го января 2008.
    Темы номера:
    - Jason Сhu извиняется за запоздалый выход очередного номера главного печатного органа нашего дистрибутива.
    - Новости Archlinux.
    - Нужна-ли Арчу стабильная ветка?
    - Интервью с отцом-основателем.
    - а также новости Линукса, хайлайты форума, смехопанорама и прочее…

P.S. Будем надеяться, что теперь новости будут обновляться оперативнее.
BugTracker теперь доступен для пакетов из community.

Community bugs

Bugtracker is open for Community packages
X.org помещен в extra. libgl-dri теперь называется libgl - пересоберите пожалуйста пакеты, которые от нее зависят.
Основные темы:
- Новый список рассылки arch-announce
- Gnome 2.20.1
- KDE 3.5.8
- Много обновлений в core

Newsletter

Newsletter for October 22, 2007
Для тех, кто не читает форум и archlinux.org(.ru) добавлен специальный список рассылки в который разработчики будут посылать только объявления.

http://archlinux.org/mailman/listinfo/arch-announce

New Announcement Mailing List
Основные темы:
- Больше не поддерживается kernel26ck
- Больше не поддерживается kernel26suspend2
- kernel 2.6.23 в testing
- db/heimdal/gtk/gnome/gcc перемещены из testing в extra

Newsletter

Newsletter for October 15, 2007
Основные темы:
- Смена лидера
- current -> core
- Релиз Don't Panic 2007.08-2
- AUR 1.4.0

Пакеты:
- Gnome 2.20 и Xorg 7.3 в testing

Темы в списках рассылки:
- confused with pacman-optimize
- GIT daemon up on projects.archlinux.org
- future pacman development

Темы в форуме:
- ArchLinux wallpapers
- Arch Linux logo
- list of MMORPG's
- Most used laptops

Newsletter

Newsletter for October 8, 2007
Judd Vinet заявил о том, что перестает быть лидером проекта Arch и предлагает кандидатуру Aaron Griffin на свое место.

Arch Leadership
Теперь большая часть модулей собрана как разделяемые объекты и уменьшено количество зависимостей.

При обновлении вам потребуется:
  • поправить конфиг, включив ранее статически вкомпилированные модули
  • т.к. уменьшено кол-во зависимостей пакета php, вам возможно потребуется для корректной работы расширений php установить дополнительные пакеты, список которых будет выведен на экран при установке.
  • Если вы пользуетесь расширениями php из community, вам придётся их пересобрать с этой версией php.

Если ваш вебсервер подключен к интернет, вы возможно захотите установить php-suhosin, перенесённый из community в extra.

PHP Update and Modularization
Gnome 2.20 заменяет репозиторий gnome (с отладочным 2.19). Не забудьте убрать его из pacman.conf.

Что нового в gnome 2.20?

GNOME 2.20 hits testing
- xorg-server 1.4
- стабильный драйвер intel
- randr 1.2
- автонастройка без xorg.conf
- обновлено ABI
- не работает legacy nvidia (71xx, 96xx)

Xorg 7.3 hits testing
util-linux-ng заменяет неподдерживаемый util-linux и является его веткой.

Обычно ничего страшного при замене util-linux на util-linux-ng не происходит и вы можете спокойно сказать пакману Y.

Домашняя страница util-linux-ng

util-linux-ng is now in the core repo
В current остается только самое необходимое, все остальное переносится в extra. После чего current переименовывается в core.

community/AUR остаются без изменений.

На время переноса остановлен rsync, так что владельцы зеркал могут не беспокоиться.

Repository Shuffle
Небольшое обновление ISO образов. В основном проблемы с ntfs разделами.

Изменения:
- ядро 2.6.22.6
- все хуки переименованы (“_” вместо “-”)
- исправлен параметр загрузки disablehooks
- #7868 запрет драйвера ntfs во время arch_addons
- добавлен ‘nfsd’ в окружение установки
- добавлен ‘top’ в окружение установки
- исправлены зависимости в окружении установки

Изменения в инсталяторе:
- #7830 Исправлены опечатки в тексте

2007.08.1 Don't Panic ISOs released
Чтобы установить beta-верисю gnome 2.19 с отладочной информацией, нужно добавить репозиторий gnome в /etc/pacman.conf:


Server = ftp:///gnome/os/i686

Собрано в testing, но должно заработать и в current. Gnome 2.19 заморожен, пришло время тестировать и сообщать об ошибках.

GNOME 2.19 packages available (i686 only)
Организованно новое зеркало ArchLinux.
Должно быть достаточно быстрым для пользователей в ру-зоне.

ftp://archlinux.org.ru/pub/archlinux/
GTK 2.10.14-1, собранное с glib 2.14.0, содержит ошибку, которая вызывает deadlocks со 100% использованием процессора в приложениях, неправильно проинициализировавших GTK. (OpenOffice.org, Flash при использовании в KDE/Qt окружении.)
Обновитесь до gtk2 2.10.14-2 или откатитесь на 2.10.13.

Lockup issues with gtk 2.10.14-1. Please upgrade to 2.10.14-2