Приветствую! Меня интересует такой вопрос: Кто нибудь смог поставить нормально дрова на такое “чудо техники”? Я использую GeForce GT 540M и не как не могу нормально установить дрова. На нтел ставится без проблем, а вот с нвидией одни проблемы, а в вики там устаревшие темы. Много что больше не актуально. Просто надоело убивать интел. Есть такой проект Bumblebee, но он тоже сырой еще. Так удалось кому-то что-то сделать?
Вышел новый официальный установочный образ, теперь только нетинстал и без AIF (((
Жаль кончено что AIF убрали… Жалуются что некому поддерживать…
Ушел в оставку Dieter Plaetinck – последний из остававшихся разработчиков команды Releng. Вот что он написал по данному поводу (оригинал):
"Несколько дней назад я ушел в отставку с поста разработчика Arch Linux (ссылка на английский текст письма об отставке).
Грустно уходить, но я чувствовал, что моя работа над Arch'ем превратилась в обузу, поэтому настало время официально зафиксировать ее понизившийся приоритет. Команды Releng, работу с которой мы начали больше 3 лет назад, сейчас уже не существует, однако другие разработчики демонстрируют интерес к созданию образов (iso) и инсталляционных скриптов, поэтому, пока их интерес не угаснет, вы будете видеть новые образы (Arch'а). Более подробная информация о моей отставке содержится в письме по приведенной выше ссылке".
В свете происходящих с дистрибутивом изменений, которые могут расцениваться как отказ от прежней – уникальной – модели развития Арча, данное событие выглядит знаковым.
http://www.archlinux.org/news/grub-lega … supported/

Разработчики Arch Linux сообщили о переводе core-компонентов дистрибутива на использование загрузчика GRUB 2. В связи с этим, прошлая стабильная ветка GRUB (0.9x) перемещена в неофициальный репозиторий AUR и больше не поддерживается. На уже установленных системах старая версия GRUB не будет обновлена автоматически и останется полностью работоспособной. Несмотря на это, пользователям подобных систем рекомендуется выполнить обновление до GRUB 2 вручную.
Наверно через чур нубовская тема, но как настроить в OpenBox"е русский язык - чтобы программы на русском по возможности ставились и, главное, как поставить русскую расскладку и как ее переключать?
Обновляюсь сегодня. Прилетела новая версия glibc. При обновлении ругнулось на то, что /lib уже в системе. И тут я совершил ошибку - запустил апргрейд с –force %) Не делайте так никогда :) Установка всё-равно грохнулась, практически пустой /lib и ни один бинарник не запускается =) Абзац, здравствуй переустановка системы. Или, может кто-нить скинет архивчик с содержимым /lib? :)
Вчера появился странный глюк – в консоли перестали работать клавиши Home и End.
Сегодня дошли руки проверить – оказалось, виноват новый xterm версии 280, пока откатил на предыдущую версию – помогло.

Сейчас буду рыть на предмет “баг или фича”, о результатах напишу здесь же.

P.S.
Похоже на баг при добавлении новой фичи:
https://bugs.archlinux.org/task/30439
http://invisible-island.net/xterm/xterm … #xterm_280 , XK_Home / XK_End
Вариант временного лечения – вместо отката можно добавить в ~/.Xresources или ~/XTerm строчку вида
XTerm*tcapFunctionKeys: true
Сегодня утречком столкнулся с проблемой:
При выключении либо перезагрузке машины всё странным образом останавливался на “демоне” bluetooh с соообщением
INIT: no more processes left in this runlevel

Сначала я решил, что это я виноват – наверное, что-то не скопировал из pacnew после обновления пакета bluez. Проверил – ничего особенного. Ладно, думаю – наверное, баг. Откатил пакет – то же самое. Более того, тут обнаружилось, что команда
/etc/rc.d/bluetooth stop
теперь неожиданным образом убивает вообще все процессы в системе, отсюда и таинственное сообщение от INIT. И от версии bluez тут на самом деле ничего не зависит. В чём дело?

Покопавшись в скрипте /etc/rc.d/bluetooth , я обнаружил там строчки вида:
    killall $PAND_NAME >/dev/null 2>&1
...
    killall $DUND_NAME >/dev/null 2>&1
...
    killall $HIDD_NAME >/dev/null 2>&1
...
    killall $SDPD_NAME >/dev/null 2>&1
...
    killall $DAEMON_NAME >/dev/null 2>&1
Четвертая строчка с переменной $SDPD_NAME и оказалось источником проблем – переменная была пустая, и вместо команды killall имя выполнялась команда killall без параметров.

А теперь вопрос на засыпку – почему раньше этот скрипт не был склонен столь эффектно “килять” вообще все процессы в системе? А потому, что сегодня утречком обновился пакет psmisc, в который и входит команда killall
Раньше killall без параметров не делал ничего, точнее выводил свой хелп. И вот после нынешнего обновления (версия psmisc-22.18-1) у него появилась эта “забавная фича” :)

Так что если у вас в DAEMONS прописан bluetooth, сохраните всё не сохранённое и проведите эксперимент – выполните под рутом
/etc/rc.d/bluetooth stop
Если после этого случится большой OVERKILL (вы поймёте, что это он), можете смело откатывать psmisc на предыдущую версию, либо, если вы старый опытный камикадзе, править конфиги bluetooth и искать у себя другие скрипты, которые грозят сотворить то же самое аналогичным способом.
Сегодня, 11 марта 2012 года исполняется ровно 10 лет с момента первого релиза дистрибутива Arch Linux (en.wikipedia.org).
http://en.wikipedia.org/wiki/Arch_Linux
Получил при обновлении такую информацию:
kmod и module-init-tools конфликтуют. Удалить module-init-tools?
Никаких новостей по этому поводу не проходило. Странно это. Появляется новый инструмент и тупо заменяет прежний, а почему и для чего – неважно?
Нарыл такое описание kmod: ANNOUNCE: kmod 1. Из русских описаний – Представлен kmod, новый инструментарий управления модулями ядра Linux.
Кто обновился, просьба отписаться о результате.
В общем, Arch в каком-то глобальном движении… (как Linux в целом).
В X.Org Server 1.11 обнаружена уязвимость, позволяющая через манипуляции с клавиатурой обойти режим блокировки экрана и получить доступ к заблокированному рабочему окружению пользователя. Проблема проявляется в дистрибутивах, перешедших на X.Org Server 1.11 (Fedora 16, Arch Linux, Gentoo, тестовый выпуск Debian Wheezy), для большинства хранителей экрана и систем блокировки экрана, включая gnome-screensaver (GNOME) и kscreenlocker (KDE).

Проблема вызвана тем, что в выпуске X.Org Server 1.11 в состав XKB была интегрирована функция принудительного завершения работы процесса, который обрабатывает текущий ввод. Функция не отражена в официальной пользовательской документации и предназначена для отладочных целей при разработке программ, эксклюзивно перехватывающих ввод (при зависании таких программ ранее было не обойтись без перезапуска X-сервера). Примечательно, что до 2008 года в состав X.Org Server входила похожая функция, управляемая опцией “Option AllowClosedownGrabs” (Ctrl+Alt+Keypad-Multiply), но данная функция была по умолчанию отключена и позднее совсем удалена из X.Org. В версии X.Org Server 1.11 работа комбинации Ctrl+Alt+Keypad-Multiply возвращена, при этом в Debian Wheezy распознаётся по умолчанию.

Работа программ блокировки экрана сводится к обеспечению постоянного перекрытия текущего содержимого рабочего стола через создание окна в полноэкранном режиме и перехвата всех событий ввода. Используя вышеотмеченную функцию, активируемую через специальную клавиатурную комбинацию (Ctrl+Alt+F11 или Ctrl+Alt+умножить на цифровой панели), можно принудительно завершить работу процесса, обслуживающего блокировку экрана, и таким образом получить доступ к рабочему столу без ввода пароля. Кроме того, среди появившихся в X.Org Server 1.11 отладочных функций также представлена возможность отключения эксклюзивного захвата событий ввода (Ctrl+Alt+F10), которую также можно использовать для обхода хранителя экрана.

В качестве обходного пути по защите от проявления уязвимости предлагается вручную отредактировать конфигурацию xkb и удалить из неё привязки клавиатурных комбинаций к событиям XF86Ungrab и XF86ClearGrab. Другим методом является использование для блокирования экрана в отдельной консоли программы vlock, которая блокирует переключение между виртуальными консолями.

Источник: http://www.opennet.ru/opennews/art.shtml?num=32844
Как стало известно нашим корреспондентам, pacman 4 совершил посадку в аэропорту core. Венки лавра достались 24 участникам, сделавших 893 улучшения в новые возможности. Среди которых подписи gpg. Их можно отключить прочитав вики или блог Алана. И да, не забудьте объединить конфигурационные файлы с *.pacnew.
На днях был релиз беты новых КЕД версии 4.8 и собранные пакеты уже есть в репозитории . (как подключить ?)

Изменения KDE:
- Qt Quick в Plasma Workspaces – Qt Quick прокладывает себе путь в Plasma Workspaces, новые компоненты Plasma предоставляют стандартизированную реализацию API виджетов с нативным внешним видом Plasma. Виджет уведомления о подключенных устройствах был портирован используя эти компоненты и сейчас он написан на чистом QML.
- Переключатель окон в KWin сейчас так же основан на QML и следует тендециям в дизайне современных переключателей окон.
- Отображение файлов в Dolphin было переписано для достижения большей производительности, расширяемости и более привлекательного внешнего вида.
- Многие улучшения производительности и багфиксы сделали работу в среде KDE более приятной, а приложения и рабочие столы стали более продукцивными.

Изменения в пакетах:
- разделены модули kdeaccessibility и kdeutils
- новый пакет kdeplasma-addons-applets-icontasks
- новый пакет kactivities (отделен от kdelibs)
- новый пакет kdeedu-analitza (отделен от kdeedu-kalgebra)
- kdeedu-kalzium имеет поддержку libfacile
- включен Open GL ES в kdebase-workspace

Для корректной установки и работы может понадобиться так же подключить репозиторий .
Так же в есть пакеты первой беты Calligra Suite.

Баги относящиеся к собранным пакетам постим сюда: https://bugs.archlinux.org .
Баги KDE постим сюда: https://bugs.kde.org .
Свои впечатления и ощущения пишем ниже.
http://www.archlinux.org/news/20110819- … ion-media/

Ждем перевод от наших переводчиков на главной.
Присоединяйтесь к нам на канале #archlinux-bugs во Freenode в это воскресенье, 21 - го августа, и помогите нам закрыть некоторые баги!

Источник: News: Bug day: Sunday, August 21th
Благодаря обновлению Linux ядра до версии 3.0, перемещенному в , пакет kernel26 переименован в linux. Аналогичные изменения сделаны для имен файлов ядра и образа инициализации:

  • vmlinuz26 теперь vmlinuz-linux
  • kernel26.img теперь initramfs-linux.img
  • kernel26-fallback.img теперь initramfs-linux-fallback.img

    Для предотвращения ситуации «не было печали», были созданы символические ссылки указывающие на старые имена файлов. Мы рекомендуем обновить файлы конфигурации загрузчика, после чего удалить символические ссылки.

    Оригинал новости.
netcfg 2.6.6 был перемещен в . Накопилось уже достаточно функционала, обеспеченного многими людьми с прошлогодней версии 2.5.4. С версии 2.6.1 по 2.6.6 были исправлены ошибки замеченные с начала релиза 2.6.

  • начальная поддержка IPv6 конфигурации
  • более детализированы wireless-опции (ad-hoc mode, network by BSSID)
  • больше возможностей для bridge-соединений
  • массив ROUTES для определения пользовательских маршрутов в профилях
  • конфигурационный файл /etc/conf.d/netcfg который в данный момент используется только net-auto-wireless
  • новые типы соединений: openvpn, vlan, tuntap
  • a manpage netcfg-profiles(5) описывает более подробно доступные опции
    Подробности об изменениях и ссылка на баг-трекер могут быть найдены в файле NEWS. Старый профили должны остатся совместимыми.

    Пожалуйста ознакомтесь со списком зависимостей, чтобы узнать что нужно установить для определенной конфигурации.

    Дополнительные функции, наиболее востребованные и указанные на баг-трекере станут доступны с релизом 2.7. Обсуждения по поводу развития netcfg и возможностей уже ведутся списке рассылке arch-projects. Не стесняйся оставить сообщение если есть желание принять участие в обсуждении или возможность помочь с патчами.

    Оригинал новости.
Хорошая KISS-новость: в положили разделенный (splitted) libreoffice!

Вольный перевод части сообщения из рассылки:
LibreOffice был разделен на libreoffice-common и пакеты приложений -writer, -base, -calc, …

Для большей интеграции с рабочим окружением, по желанию можно установить libreoffice-gnome или libreoffice-kde4 для gtk- и qt-окружения соответственно.
Языковой пакет en-US больше не включается в пакет -common, поэтому всем придется устанавливать как минимум один языковой пакет, т.е. libreoffice-en-US.

Вы можете пойти двумя путями: или установить libreoffice-common, который попросит установить языковой пакет, или установить языковой пакет, который потянет за собой libreoffice-common.

Так же возможно установить групповой пакет “libreoffice”.
Будущая версия initscripts-2011.06.1, которая сейчас находится в , несет с собой изменения в конфигурации модулей ядра и их автозагрузки - в строке MODULES нельзя будет “блэклистить” модули (“!mod_name”), так же скрипт больше не воспринимает параметр MOD_AUTOLOAD. Отныне модули, которые необходимо убрать из автозагрузки, следует указывать в /etc/modprobe.d/, а вкл./выкл. автозагрузки модулей осуществляется непосредственно с помощью udev.

Официальный анонс будет позже.
Сабж
Когда ждать в репах?