Дефектные обновления [Core, Extra, Community, Multilib]

У reflector проблемы с получением списка зеркал
https://gitlab.archlinux.org/archlinux/packaging/packages/reflector/-/issues/2
похоже связано с тем что нет рабочих зеркал синхронизированных на сто процентов либо же неправильно отображается их статус
https://archlinux.org/mirrors/status/

у кого включен сервис могут быть проблемы, пока рекомендуется временно отключить его и прописать сервера вручную
либо же запускать с параметром completion-percent около 90
например
reflector --protocol https --latest 5 --age 24 --sort rate --completion-percent 95 --save /etc/pacman.d/mirrorlist
ddcutil 2.1.0-1 вызывает краш у powerdevil в KDE

откат на ddcutil 2.0.0 помогает

upd
прилетело 2.1.0-2, которое решило проблему

upd2
но при этом 2.1.0 не работает, такие ошибки пишет
(i2c_open_bus                  )           busno=0, flock() returned: EAGAIN(-11): Resource temporarily unavailable
Max wait exceeded for /dev/i2c-0
Programs holding /dev/i2c-0 open:
COMMAND   PID USER FD   TYPE DEVICE SIZE/OFF NODE NAME
ddcutil 28187 gray 3u   CHR   89,0      0t0  399 /dev/i2c-0
sh      28209 gray 3u   CHR   89,0      0t0  399 /dev/i2c-0
COMMAND   PID USER FD   TYPE DEVICE SIZE/OFF NODE NAME
ddcutil 28187 gray 3u   CHR   89,0      0t0  399 /dev/i2c-0
sh      28212 gray 3u   CHR   89,0      0t0  399 /dev/i2c-0
Processes locking /dev/i2c-0 (inode 399):
2207
2207
egrep: warning: egrep is obsolescent; using grep -E
Name:        org_kde_powerde
State:       S (sleeping)
Pid: 2207
egrep: warning: egrep is obsolescent; using grep -E
Name:        org_kde_powerde
State:       S (sleeping)

откатился на 2.0.0
upd
в версии 2.1.0-3 всё исправили
Сегодня обновилось "Libplacebo" И кое какие проги не запускаются к примеру Телеграм Вот его вывод telegram-desktop: error while loading shared libraries: /usr/lib/libplacebo.so.338: file too short НО хотя он обновился НО не установился его нет! Пишет libplacebo: '/usr/include/libplacebo/colorspace.h' существует в файловой системе и таких сообщений куча) Проверяю pacman -Qi libplacebo
ошибка: пакет 'libplacebo' не найден
Что подскажите? PS И откатить невозможно есть файлы и все!!!
deep
Сегодня обновилось "Libplacebo"
[wolf@wolf-pc ~]$ pacman -Qii libplacebo
Название             : libplacebo
Версия               : 6.338.2-1
Описание             : Reusable library for GPU-accelerated video/image rendering primitives
Архитектура          : x86_64
URL                  : https://github.com/haasn/libplacebo
Лицензии             : LGPL-2.1-or-later
Группы               : Нет
Предоставляет        : libplacebo.so=338-64
Зависит от           : vulkan-icd-loader  libvulkan.so=1-64  glslang  lcms2  liblcms2.so=2-64  shaderc  libshaderc_shared.so=1-64  glibc  gcc-libs  libunwind
                       libdovi.so=3-64  xxhash
Доп. зависимости     : Нет
Требуется            : ffmpeg  mpv
Опционально для      : Нет
Конфликтует с        : Нет
Заменяет             : Нет
Установленный размер : 1577,73 KiB
Сборщик              : Robin Candau <[email protected]>
Дата сборки          : Вт 23 янв 2024 10:56:40
Дата установки       : Вт 23 янв 2024 18:36:49
Причина установки    : Установлен как зависимость другого пакета
Установочный скрипт  : No
Проверен             : Подпись
Резервные копии      :
(пусто)
Никаких проблем.

deep
НО хотя он обновился НО не установился его нет! Пишет libplacebo: '/usr/include/libplacebo/colorspace.h' существует в файловой системе и таких сообщений куча) Проверяю pacman -Qi libplacebo
ошибка: пакет 'libplacebo' не найден
Что подскажите? PS И откатить невозможно есть файлы и все!!!
Это не дефектное обновление, это проблема лично твоей системы и не полного обновления.
sudo pacman -Syu libplacebo --overwrite="*"
https://t.me/arch_linuxru
sudo pacman -Suy --overwrite libplacebo
:: Обновление баз данных пакетов...
core is up to date
extra is up to date
multilib is up to date
:: Запускается полное обновление системы...
делать больше нечего
[sergey@localhost ~]$ pacman -Qi libplacebo
ошибка: пакет 'libplacebo' не найден
deep
sudo pacman -Suy –overwrite libplacebo
А теперь без отсебятины, выполни команду, которую я тебе написал.
https://t.me/arch_linuxru
О!!! Блин я же вводил вашу команду но выскочила ошибку типа нет файла "overwrite" , сейчас снова ввел и все сработала!
Спасибо друг!!! Аха нашел косяк был пробел был перед "overwrite" вот так "-- overwrite"
После последнего обновления перестал корректно работать звук. Почти на всех сайтах кроме ютуба звук бубнящий, скрежечащий. При том, локальные видео и музыка нормально воспроизводятся, но на внейшний ЦАП. Если выводить на монитор, то звук такой же кривой. Пробовал откатить пакеты, но особого результата это не принесло.

Помню сталкивался уже с подобными приколами, решилось с последущими обновлениями.

Может кто сталкивлся. В чем проблема? Какие пакеты сломались.

UPD: Пробелма оказалась в браузере. Помогла полная очистка кэша и конфигов, а так же переустановка.
 
Зарегистрироваться или войдите чтобы оставить сообщение.