Дефектные обновления [Core, Extra, Community, Multilib]

nafanja
тут дело не в хотении, а в правильности.
А я о чем? Правильнее как сейчас, а не ваши хотелки.
Ну или if)))
Lupus pilum mutat, non mentem.
jim945
nafanja
тут дело не в хотении, а в правильности.
А я о чем? Правильнее как сейчас, а не ваши хотелки.
Ну или if)))
а можно конкретнее какие хотелки? а то по ссылке там никаких хотелок нет, а вот ниже они четко просматриваются не у меня в посте.

да и вообще, если ты не заметил, то уже некоторые пакеты с левыми модулями заменились на dkms варианты.
так что все идет в правильном русле. а я просто констатировал факт.
скоро и у nvidia останутся только dkms варианты. дальше логичен и перенос заголовков стандартного ядра из дополнительных в обязательные.
а вот добавление в обязательные заголовков других ядер не входящих в base алогичен.
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
то уже некоторые пакеты с левыми модулями заменились на dkms варианты.
При этом все расписано в pacman log ….. и такой принцип лично мне нравится..... PS.... пример с того года.....
installed sysdig (0.4.0-1)
Creating symlink /var/lib/dkms/sysdig/0.4.0/source -> /usr/src/sysdig-0.4.0
DKMS: add completed.
==> To build and install the necessary module run: dkms install sysdig/0.4.0
==> To do this automatically at startup run: systemctl enable dkms.service
Ошибки не исчезают с опытом - они просто умнеют
nafanja
а можно конкретнее какие хотелки?
nafanja
а так да, должно быть в обязательных зависимостях.
Lupus pilum mutat, non mentem.
nafanja
пакеты с левыми модулями заменились на dkms варианты.
так что все идет в правильном русле.
То есть все идет к универсальности. А ни как раньше: одно ядро + готовые модули для него.
Стали появляться новые ядра, стали плодиться пакеты с модулями под каждое.
Сделали универсльный вариант с dkms. Логично.
nafanja
дальше логичен и перенос заголовков стандартного ядра из дополнительных в обязательные.
Плевать на универсальность. Пользуйтесь стандартным ведром.
Логика где?
Не будет такого 100%. Всем это и так понятно.
Lupus pilum mutat, non mentem.
jim945
Плевать на универсальность. Пользуйтесь стандартным ведром.
не верное суждение!
ты ж понимаешь что все идет последовательно. сначала добавят заголовки стандартного ядра, так как работы всего то изменить 2 строки в PKGBUILD пакета dkms, чем перекроют нужды большинства. а уж потом когда нибудь может и IF сделают.
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
сначала добавят заголовки стандартного ядра, так как работы всего то изменить 2 строки в PKGBUILD пакета dkms
Уже добавили. Теперь смотрим к чему это привело.
 yaourt -R linux-headers
проверка зависимостей...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: virtualbox-host-dkms: удаление linux-headers ломает зависимость 'linux-headers'
А если я не пользуюсь стандартным ядром? От слова совсем. Нахрена эта зависимость?
Это абсолютно неправильно.
Lupus pilum mutat, non mentem.
Мне как простому пользователю как бы плевать на то, правильно это или нет. Меня интересовал конкретный инцидент с VirtualBox. Виртуалка пять лет работала без linux-headers, а тут...
jim945
Вообще-то при обновлении virtualbox-host-dkms выводилось предупреждение
Доп. зависимости     : linux-headers
linux-lts-headers
Нужно быть внимательнее.
Таких сообщений может быть тьма и если оно и было я его пропустил. Кто ж смотрит на доп. зависимости? В общем понимании это что-то опциональное и ставится при необходимости, а если без этого софтина не работает, какая же это доп. зависимость?
Понятно следующее: оказывается при обновлении VirtualBox надо было внимательно читать англоязычную вику:
install the virtualbox package. virtualbox-host-dkms will also be installed as a required dependency. To compile the virtualbox modules provided by virtualbox-host-dkms, it will also be necessary to install the appropriate headers package(s) for your installed kernel(s):
linux kernel: linux-headers


Потому как в русскоязычной все понятно:
Если вы используете собственное ядро из AUR репозитория, убедитесь, что установлен пакет linux-headers.

У меня, как и у большинства, не кастомное ядро. А значит предупреждение должно было быть более значительным. Например, новость.
Пива много не бывает.
не туда его влепили. (((
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
Aivar, то что virtualbox-host-dkms заменял virtualbox-host-modules и pacman об этом спросил вас не смутило?
Почему бы тогда пакет linux не привязать в обязательные зависимости всех пакетов, ведь он в группе base.
Lupus pilum mutat, non mentem.
 
Зарегистрироваться или войдите чтобы оставить сообщение.