Дефектные обновления [Core, Extra, Community, Multilib]

nafanja
Само прилетело. Бардак в том, что linux-headers, имхо, теперь должен быть в обязательных зависимостях у virtualbox-host-dkms, а не в необязательных, как сейчас.
Пива много не бывает.
Aivar
Понадобилось с полчаса, чтобы допереть, что теперь для сборки оного требуется linux-headers, который раньше никогда у меня не был установлен.
Уже было - http://archlinux.org.ru/forum/topic/15842/?page=1
teplovoz, пардон, не читал.
Пива много не бывает.
Aivar
Само прилетело.
ну хоть какое то продвижение в правильную сторону dkms, а то распространять левые модули в бинарниках лишнее!
Aivar
Бардак в том, что linux-headers, имхо, теперь должен быть в обязательных зависимостях у virtualbox-host-dkms, а не в необязательных, как сейчас.
на самом деле не у этого пакета, а у пакета dkms.
а так да, должно быть в обязательных зависимостях.
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
а так да, должно быть в обязательных зависимостях.
Тогда в зависимостях нужно будет добавлять поддержу if от версии ядра.
Lupus pilum mutat, non mentem.
jim945
Тогда в зависимостях нужно будет добавлять поддержу if от версии ядра.
можно и без if, если считать что стандартное ядро есть у всех, а у кого другое должны знать сами что нужно доставить пакет с заголовками соответствующей версии.
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
стандартное ядро есть у всех
Это которое linux или linux-lts? )))
Lupus pilum mutat, non mentem.
которое linux из группы base
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
которое linux из группы base
"А я хочу суперстабильности c lts и чтоб все автоматом."
Нефиг. Либо всем, либо никому. Читать вывод пакмена нужно.
Lupus pilum mutat, non mentem.
jim945
Нефиг. Либо всем, либо никому. Читать вывод пакмена нужно.
будет lts в base тогда не вопрос, пусть будут в зависимостях и lts заголовки!
jim945
"А я хочу суперстабильности c lts и чтоб все автоматом."
тут дело не в хотении, а в правильности.
правильно это то что пакеты из base имеют максимальный приоритет и от них все отталкиваются!!!
а так же правильно то, что в базе не нужны дублирующие пакеты. для сборки дублирующих пакетов сборщики тратят свое время которое могли бы потратить на другое.
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
 
Зарегистрироваться или войдите чтобы оставить сообщение.