[ РЕШЕНО ] Не выключается ноут

vs220
Не, только инглиш.
Тогда увы... По части английского меня самого надо в багтрекер записать. Вот если бы по-французски - тогда милое дело бы было ))
yurius
Вот если бы по-французски
а какая разница-то? языки одинаковые, ну слова некоторые различаются немного ;)
такие дела.
cucullus
а какая разница-то? языки одинаковые, ну слова некоторые
шо там учить?
Linux Forever!
UPD

Сегодня было обновление ядра, и в новом 5.15.3 всё починили, паршивцы - ноут выключается и перезагружается корректно. Оставил себе также и LTS, ибо, как в том анекдоте про Винни Пуха и Пятачка - "От вас, свиней, всего можно ожидать".

То есть, как я и предполагал, проблема была в ядре.
yurius
Оставил себе также и LTS
он быть обязан ...

yurius
как я и предполагал, проблема была в ядре
предполагать это хорошо, но лучше еще и проверять/уточнять ...
Ошибки не исчезают с опытом - они просто умнеют
Ребята, подскажите, плз, вот что. Как я писал выше, у меня сейчас есть 2 ядра - обычное и LTS. Только теперь при обновлении одного из них, именно оно начинает грузиться по умолчанию. Как сделать, чтобы по умолчанию всегда грузилось только обычное?

При загрузке, на экране рефинда основная (первая) кнопка грузит систему по умолчанию. Если нажать F2, то откроется субменю, и там можно выбрать как обычное ядро, так и LTS. Но можно сделать, чтобы не нужно было нажимать F2 и грузилось обычное? А то теперь приходится переустанавливать linux, если обновилось linux-lts, ибо именно оно после обновления начинает грузиться вместо linux. Могу конечно внести lts в IgnorePkg, но не хочется зверствовать. А так не пойму, в каких .confах прописать порядок загрузки.
yurius
в каких .confах прописать порядок загрузки.
https://wiki.archlinux.org/title/REFInd#Configuration

Кто первый прописан → того и тапки

Или в конфиге пункты прописать и указать
default_selection (в примере default_selection "Arch Linux" пункт по умолчанию →menuentry "Arch Linux")

например мой ( пути к файлам свои должны быть)
[[email protected] ~]$ cat /boot/EFI/Boot/refind.conf

timeout 18
banner /EFI/Boot/background.png
#banner_scale fillscreen
resolution 1024 768
use_graphics_for linux
showtools shutdown,reboot,shell,modelist
uefi_deep_legacy_scan false
dont_scan_volumes "ARCH1" "EFI system partition" "EFI_ARCH" "arch" "M-PM-^RM-PM->M-QM-^AM-QM-^AM-QM-^BM-PM-0M-PM-=M-PM->M-PM-2M-PM-8M-QM-^BM-QM-^L" "vindata"
dont_scan_files shim.efi,MokManager.efi

#scan_all_linux_kernels false
#extra_kernel_version_strings linux-lts,linux
icons_dir icons
selection_big   themes/rEFInd-minimal/selection_big.png
selection_small themes/rEFInd-minimal/selection_small.png
default_selection "Arch Linux"
menuentry "Arch Linux" {
    icon /EFI/Boot/icons/os_arch.png
    volume   ARCH1
    loader   /boot/vmlinuz-linux
    initrd   /boot/initramfs-linux.img
    options  "root=UUID=f380ec9b-ada5-4f62-a9be-588ef0c955f5 rootfstype=ext4 rootflags=rw,noatime,nodiratime sysrq_always_enabled=1 module_blacklist=8021q,cfg80211,pcspkr nvidia-drm.modeset=1 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off rhgb quiet loglevel=3 rd.udev.log_priority=3 vt.global_cursor_default=0 add_efi_memmap resume=UUID=d5ff0a27-4bee-46d4-a0a2-f52e2d9905cc initrd=\boot\intel-ucode.img"
    submenuentry "Boot using fallback initramfs" {
        initrd /boot/initramfs-linux-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "emergency"
    }
    submenuentry "Boot to rescue" {
        add_options "systemd.unit = rescue.target"
    }
}
menuentry "Windows" {
icon /EFI/Boot/icons/os_win8.png
 loader \EFIMicrosoft\Boot\bootmgfw.efi
 }

menuentry "linux-lts" {
    icon /EFI/Boot/icons/os_unknown.png
    volume   ARCH1
    loader   /boot/vmlinuz-linux-lts
    initrd   /boot/initramfs-linux-lts.img
    options  "root=UUID=f380ec9b-ada5-4f62-a9be-588ef0c955f5 rootfstype=ext4 rootflags=rw,noatime,nodiratime module_blacklist=8021q,cfg80211,pcspkr nvidia-drm.modeset=1  add_efi_memmap  initrd=\boot\intel-ucode.img"
    submenuentry "Boot using fallback initramfs" {
        initrd /boot/initramfs-linux-lts-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "emergency"
    }

menuentry "framebuffer resolutions" {
icon /EFI/Boot/icons/tool_shell.png
   loader \EFI\Boot\tools_x64\modelist.efi
 }
vs220
default_selection (в примере default_selection "Arch Linux" пункт по умолчанию →menuentry "Arch Linux")
Ни черта у меня не работает. Вот какой сейчас

cat /boot/EFI/refind/refind.conf

.......

default_selection "Arch Linux"

menuentry "Arch Linux" {
    icon     /EFI/refind/icons/os_arch.png
    volume   "Arch Linux"
    loader   /boot/vmlinuz-linux
    initrd   /boot/initramfs-linux.img
    options  "root=PARTUUID=b0a8e989-2e60-4a62-9529-8da24ffb3121 initrd=boot\amd-ucode.img rw add_efi_memmap"
    submenuentry "Boot using fallback initramfs" {
        initrd /boot/initramfs-linux-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "systemd.unit=multi-user.target"
    }
    disabled
}

menuentry "Arch Linux LTS" {
    icon     /EFI/refind/icons/os_arch.png
    volume   "Arch Linux"
    loader   /boot/vmlinuz-linux-lts
    initrd   /boot/initramfs-linux-lts.img
    options  "root=PARTUUID=b0a8e989-2e60-4a62-9529-8da24ffb3121 initrd=boot\amd-ucode.img rw add_efi_memmap"
    submenuentry "Boot using fallback initramfs LTS" {
        initrd /boot/initramfs-linux-lts-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "systemd.unit=multi-user.target"
    }
    disabled
}
......

- но всё равно упорно грузится LTS по умолчанию.
vs220
Кто первый прописан → того и тапки

Это вот тут что ли? /boot/refind_linux.conf ? Вот что у меня там:

"Boot with standard options"  "root=UUID=b0a8e989-2e60-4a62-9529-8da24ffb3121 rw"
"Boot to single-user mode"    "root=UUID=b0a8e989-2e60-4a62-9529-8da24ffb3121 rw single"
"Boot with minimal options"   "root=UUID=b0a8e989-2e60-4a62-9529-8da24ffb3121 ro"
Если же прописать в первом пункте

"Boot using default options"     "root=PARTUUID=XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX rw add_efi_memmap initrd=boot\amd-ucode.img initrd=boot\initramfs-linux.img"
, как в Вике, то загрузка просто не происходит: жму на кнопку с пингвином, мигает экран, и возвращается экран рефинда.
Полный конфиг выложите и
ls  /boot/EFI
efibootmgr -v
автоопределение закомментировали?

#extra_kernel_version_strings linux-lts,linux
/boot/refind_linux.conf переместить пока куданибудь
 
Зарегистрироваться или войдите чтобы оставить сообщение.