[ РЕШЕНО ] Не выключается ноут

vs220
Это параметры ядра их можно в любой загрузчик добавить
А как тогда это будет для refind звучать?
yurius
как тогда это будет для refind звучать?
Так же само в конфиг рефинда в параметры ядра добавить acpi=force
https://wiki.archlinux.org/title/kernel_parameters#rEFInd
Но тут скорее всего ядро виновато, вы lts не пробовали?
vs220
acpi=force
- ничего не дало.

vs220
вы lts не пробовали?
Нет. Стоит попробовать или лучше забить и подождать обновление ядра?

Но комп-то выключается, вот в чём прикол.
yurius
комп-то выключается, вот в чём прикол.
Таблицы acpi разные, и взаимодействие с ним разное.
Имхо стоит попробовать lts , да и держать его как запасное или основное. Незабудьте поставить и хедеры для него и драйвера если используете dkms или нвидию
vs220
и драйвера если используете dkms или нвидию
Не совсем понял, какие драйвера. dkms использую, нвидию - нет. Я установил linux-lts и linux-headers-lts, подправил /boot/loader/entries/arch.conf под них, перезагрузился. Итог - загрузка остановилась на надписи

Unknown filesystem type: ext4
rootfs #
и не работает даже клавиатура. Вернул всё назад.
yurius
подправил /boot/loader/entries/arch.conf
причем тут он если вы рефинд использовали
Рефинд и сам ядра определяет, если в конфиге разрешено
Должна быть раскомментирована строчка в конфиге extra_kernel_version_strings linux-lts,linux
yurius
Unknown filesystem type: ext4
rootfs #
Скорее всего неправильно указали initrd , указали initramfs-linux.img от обычного ядра а не от lts.
Возможно если boot отдельным разделом место в нем закончилось
Исправьте и попробуйте снова

yurius
Вернул всё назад.
ядра то друг другу не мешают, просто выбераете в загрузчике пункт загрузки нужного ядра.
vs220
Скорее всего неправильно указали initrd , указали initramfs-linux.img от обычного ядра а не от lts.
Наоборот, в arch.conf я как раз указал vmlinuz-linux-lts и initramfs-linux-lts.img - и это и привело к незагрузке. Убрал -lts, раскомментировал строчку в конфиге "extra_kernel_version_strings linux-lts,linux", и всё загрузилось. Так что проблема - вы правы - была в ядре, теперь ноут выключается корректно, задача РЕШЕНА установкой ядра LTS, спасибо! Заодно в /boot/loader/entries создал 2 конфига, которые грузят в консоль как обычное ядро, так и lts.

Но вопрос - а нужен ли вообще arch.conf, если

vs220
Рефинд и сам ядра определяет, если в конфиге разрешено
, а прописывание там реально установленного ядра ведёт к ошибке? То есть непохоже, что он ни на что не влияет...
yurius
Так что проблема - вы правы - была в ядре, теперь ноут выключается корректно
Не факт, что проблема в ядре - рекомендую проверить, для чего загрузись и проверь работу комбинаций
- для перегрузки: ALT+SysRq+R E I S U B
- для выключения: ALT+SysRq+R E I S U O
… не забываем, что для работы этих комбинация sysrq должен быть равен 1 (cat /proc/sys/kernel/sysrq = 1)
Если эти комбинации не работает, то это ошибка ядра, но если работают, то ядро не причем ... обычно это проверяют в 1-ую очередь.
Ошибки не исчезают с опытом - они просто умнеют
yurius
прописывание там реально установленного ядра ведёт к ошибке? То есть непохоже, что он ни на что не влияет..
Подобная ошибка характерна для не загруженного правильного initramfs, может все же где то ошиблись в синтаксе.
У меня с таким конфигом лтс грузит ( автоопределение, сканирование отключено пункты вручную прописаны )
 [[email protected] ~]$  cat  /boot/EFI/Boot/refind.conf

timeout 18
banner /EFI/Boot/background.png
#banner_scale fillscreen
resolution 1024 768
use_graphics_for linux
showtools shutdown,reboot,shell,modelist
uefi_deep_legacy_scan false
dont_scan_volumes "ARCH1" "EFI system partition" "EFI_ARCH" "arch" "M-PM-^RM-PM->M-QM-^AM-QM-^AM-QM-^BM-PM-0M-PM-=M-PM->M-PM-2M-PM-8M-QM-^BM-QM-^L" "vindata"
dont_scan_files shim.efi,MokManager.efi

#scan_all_linux_kernels false
#extra_kernel_version_strings linux-lts,linux
icons_dir icons
selection_big   themes/rEFInd-minimal/selection_big.png
selection_small themes/rEFInd-minimal/selection_small.png
default_selection "Arch Linux"
menuentry "Arch Linux" {
    icon /EFI/Boot/icons/os_arch.png
    volume   ARCH1
    loader   /boot/vmlinuz-linux
    initrd   /boot/initramfs-linux.img
    options  "root=UUID=f380ec9b-ada5-4f62-a9be-588ef0c955f5 rootfstype=ext4 rootflags=rw,noatime,nodiratime sysrq_always_enabled=1 module_blacklist=8021q,cfg80211,pcspkr nvidia-drm.modeset=1 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off rhgb quiet loglevel=3 rd.udev.log_priority=3 vt.global_cursor_default=0 add_efi_memmap resume=UUID=d5ff0a27-4bee-46d4-a0a2-f52e2d9905cc initrd=\boot\intel-ucode.img"
    submenuentry "Boot using fallback initramfs" {
        initrd /boot/initramfs-linux-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "emergency"
    }
    submenuentry "Boot to rescue" {
        add_options "systemd.unit = rescue.target"
    }
}
#menuentry "Windows" {
#icon /EFI/Boot/icons/os_win8.png
#  loader \EFIMicrosoft\Boot\bootmgfw.efi
# }

menuentry "linux-lts" {
    icon /EFI/Boot/icons/os_unknown.png
    volume   ARCH1
    loader   /boot/vmlinuz-linux-lts
    initrd   /boot/initramfs-linux-lts.img
    options  "root=UUID=f380ec9b-ada5-4f62-a9be-588ef0c955f5 rootfstype=ext4 rootflags=rw,noatime,nodiratime module_blacklist=8021q,cfg80211,pcspkr nvidia-drm.modeset=1  add_efi_memmap  initrd=\boot\intel-ucode.img"
    submenuentry "Boot using fallback initramfs" {
        initrd /boot/initramfs-linux-lts-fallback.img
    }
    submenuentry "Boot to terminal" {
        add_options "emergency"
    }

#menuentry "framebuffer resolutions" {
#icon /EFI/Boot/icons/tool_shell.png
#   loader \EFI\Boot\tools_x64\modelist.efi
# }

Если дополнительных параметров не надо то вполне можно оставить автоопределение
vasek
SysRq
У меня на ноуте нет кнопки SysRq.
 
Зарегистрироваться или войдите чтобы оставить сообщение.