[решено]/boot/grub.cfg убрать все упоминания /dev/sda /dev/sdb

RusWolf
такого провала я не ожидал... долго не мог понять где там /dev/sda1 найдено и почему в качестве доказательств используется пункт меню
AZJIO
такого провала я не ожидал…
доверяй НО проверяй!
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
если так все хорошо,почему тогда система не всегда загружалась,искала ядро на sdbx или sdax?
}
menuentry 'Artix Linux (on /dev/sda5)' --class artix --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-e8b3fbca-7e02-4dc2-9497-4053428021b1' {
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos5'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5  e8b3fbca-7e02-4dc2-9497-4053428021b1
	else
	  search --no-floppy --fs-uuid --set=root e8b3fbca-7e02-4dc2-9497-4053428021b1
	fi
	linux /boot/vmlinuz-linux root=/dev/sda5
	initrd /boot/initramfs-linux.img
может предпоследняя строчка?
а вот это не влияет?
set root='hd0,msdos5'
Linux Forever!
Vadim
root=/dev/sda5
так и говори!!!! а то фигней страдаешь
ответ в этом
anode
nafanja
а по умолчанию генерируется конфиг использующий UUID!!!
Та да, это я запутался. Как раз и раскоментировал GRUB_DISABLE_LINUX_UUID=true. И морочу голову
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
у меня закоментировано,откуда тогда надпись?
Linux Forever!
Vadim
у меня закоментировано,откуда тогда надпись?
твои ручки постарались...

восстанови как было и все будет...
скрипты генерации работают у миллионов, это только у тебя так....
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
	linux /boot/vmlinuz-linux root=/dev/sda5
а эта строка поддверждает мои слова!!! знающие подтвердят!!!
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
Vadim
linux /boot/vmlinuz-linux root=/dev/sda5
Вот лучше расскажи откуда у тебя тут это.
Остальное не так важно, как тут, прямое указание откуда грузить образ ядра.
nafanja
твои ручки постарались…
какие ручки?
ничего не менял,настройки дефолтные.

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_THEME=/usr/share/desktop-base/grub-themes/desktop-grub-theme/theme.txt
Linux Forever!
Vadim
ничего не менял,настройки дефолтные
sudo cat $(find /etc/grub.d) |grep root=
?
ну и на тех системах где автоконфигуратор запускали у вас же их несколько
sudo cat $(find /куда смонтировали/etc/grub.d) |grep root=
 
Зарегистрироваться или войдите чтобы оставить сообщение.