[решено] запуск приложений ломает звук

pavelchavyr, а топикстартер ничего не делает для локализации проблемы.
Чтобы микшер (программный или аппаратный) смешивал разные сигналы их нужно привести к единому типу сэмпла. И кажется мне, что причина трабла была указана в этом посте.
Пива много не бывает.
pavelchavyr
Эта карта поддерживает аппаратно разные частоты дискредитации. Браузер работает через пульсу, которая принудительно пересемплирует все потоки в один. Но если какое-то приложение при этом пытается обратиться напрямую к алсе, то может переключить частоту и тогда звуки от браузера становятся искаженными.
пакет pulseaudio-alsa установлен?
установлен
Aivar
pavelchavyr, а топикстартер ничего не делает для локализации проблемы.
Чтобы микшер (программный или аппаратный) смешивал разные сигналы их нужно привести к единому типу сэмпла. И кажется мне, что причина трабла была указана в этом посте.
просто даже не знаю что мне добавить
tproo
При запуске приложений ломается звук.
Каких приложений? Куда они выводят звук?

tproo
После этого запустить телегу
Какую телегу?
Пива много не бывает.
Aivar
tproo
При запуске приложений ломается звук.
Каких приложений? Куда они выводят звук?

tproo
После этого запустить телегу
Какую телегу?
телега - телеграм. после включения музыки в браузере пробовал запустить доту, под вином subnautica, wow. После запуска чего-либо из перечисленного звук везде ломается. В вине пульса в winecfg. Дота и телеграм - не знаю.
Настройка pulseaudio производилась?
Попробуйте указать в /etc/pulse/daemon.conf
default-sample-rate = 48000
tproo
Купил внешнюю аудиокарту, и тут понесло.
Может это нужно : Выписка из..
Если вы используете несколько звуковых карт, то вам необходимо установить внешнюю аудиокарту как устройство по умолчанию. Создайте следующий файл
/etc/modprobe.d/alsa.conf
options snd slots=snd_usb_audio 
pavelchavyr
Настройка pulseaudio производилась?
Попробуйте указать в /etc/pulse/daemon.conf
default-sample-rate = 48000
сделал

beisic
tproo
Купил внешнюю аудиокарту, и тут понесло.
Может это нужно : Выписка из..
Если вы используете несколько звуковых карт, то вам необходимо установить внешнюю аудиокарту как устройство по умолчанию. Создайте следующий файл
/etc/modprobe.d/alsa.conf
options snd slots=snd_usb_audio 
тоже сделал

не уверен что именно помогло, но звук больше не ломает. большое спасибо
tproo. если вопросов больше нет, укажите что РЕШЕНО, отредактировав 1-ый пост топика.
beisic
Может это нужно : Выписка из..
Нет, это не нужно. В данной статье приводятся настройки алсы, а человек использует пульс. Пульсаудио сам разбирается с приоритетами звуковых устройств, на нумерацию и последовательность инициализации устройств ядром ему фиолетово.
Более того, если бы проблема была с неправильным выбором устройства, то звук бы вообще пропадал, а не искажался.
 
Зарегистрироваться или войдите чтобы оставить сообщение.