skype умер

Eva_Berg
# echo -n 8 | dd of=/usr/bin/skype bs=1 seek=23370360 conv=notrunc
Зря ты применила эту команду - в результате этого записался символ 8 (точнее записался байт 38) вместо символа, расположенного по смещению 233703601
Посмотреть можно так - hexdump -C -s 23370360 -n 1 /usr/bin/skype
sirocco
sed -i 's/4\.3\.0\.37/8\.3\.0\.37/' /usr/bin/skype
Должно сработать для версии 4.3.0.37

Два вопроса
- эта магическая команда помогла кому-нибудь?
- есть ли хоть доля уверенности, что это лекарство будет дествовать долго?

amon
- эта магическая команда помогла кому-нибудь?
да, народ пишет, что помогает
это с другого форума
после "патча" вышел/зашел без проблем, файлик (config.xml) уменьшился на 2 байта
костыль рабочий, на 3-х компах спокойно зашло
Gnome 2 >> Unity >> KDE 4 >> Openbox >> Awesome >> Xmonad
GitHub , BitBuket
Мне в скайпе нужен только чат, вот думаю может установить pidgin c плагинами, да и шут с ним.
In Tux We Trust
В части патча
sed -i 's/4\.3\.0\.37/8\.3\.0\.37/'
не понятно. Это простая замена в файле выражения "4.3.0.37" на "8.3.0.37".
И как это помогает? Не ужели больше ничего не влияет? Подозрительно.
Я уже скайп выкинул около года назад - за не надобностью, а потому даже и проверить не могу.
очевидно, что мелкомягкие просто не хотят поддерживать эту версию
все россказни об улучшении производительности, новых фишках, изменениях в протоколе и т.п. - пустой трёп
вот и замутили на серверах скрипт, который определяет версию клиента и отказывает в авторизации, если версия ниже 8
не думаю, что там что-то серьёзнее, т.к. данный костыль с подменой версии людям помогает - сабж запускается, авторизуется и нормально работает.
причём, на разных линухах

P.S> сам им не пользуюсь уже пару лет, хватает телеграма
Gnome 2 >> Unity >> KDE 4 >> Openbox >> Awesome >> Xmonad
GitHub , BitBuket
В части
# echo -n 8 | dd of=/usr/bin/skype bs=1 seek=23370360 conv=notrunc
Если комбинация 4.3.0.37 встречается в файле только один раз и начинается с адреса
23370361 (1649A79), то это равносильно патчу
sed -i 's/4\.3\.0\.37/8\.3\.0\.37/'
Может кто вывести
# hexdump -C -s 23370360 -n 8 /usr/bin/skype
Haron_Prime
вот и замутили на серверах скрипт, который определяет версию клиента и отказывает в авторизации, если версия ниже 8
Если это патч (с заменой 4 на 8) действительно работает, то с большой долей вероятности так оно и есть.
Он таки работает. Я кинул цитату отсюда и ссылку на лор на бубнофоруме - уже несколько человек отписались, что помогает (цитаты двоих я привёл выше).
Возможно, что после того, как информация об этом костыле дойдёт до мелкомягких, они попытаются придумать что-то более хитрое, чтобы не давать людям возможности использовать более старую версию клиента. Но пока что это работает.
Gnome 2 >> Unity >> KDE 4 >> Openbox >> Awesome >> Xmonad
GitHub , BitBuket
to Eva_Berg
Похоже (но нужно проверить) действия команд
echo -n 8 | dd of=/usr/bin/skype bs=1 seek=23370360 conv=notrunc
sed -i 's/4\.3\.0\.37/8\.3\.0\.37/' /usr/bin/skype
совпадают. Так что был не прав, когда написал - "Зря ты применила эту команду"
 
Зарегистрироваться или войдите чтобы оставить сообщение.