Пропадает видеосигнал при загрузке, если подключены два монитора

alfanobot
alien175, скажите пожалуйста, почему вы считаете что моя проблема как-то связана с иксами, если изображение пропадает на этапе голой консоли, когда иксы не запущены?
Не связана. Но Xorg-логи могут подсказать верное направление.
vs220, когда я ставлю nomodeset, оба монитора работают, но само собой, иксы не запускаются, так что этот вариант не катит.

я проделывал следующую последовательность шагов:
1. вставлял "amdgpu" в MODULES в /etc/mkinitcpio.conf (как описано тут)
2. ничего не изменилось
3. устанавливаю GRUB_TERMINAL_OUTPUT=console
4. ничего не изменилось
5. GRUB_GFXPAYLOAD_LINUX=text
6. это привело к изменению разрешения экрана в консоли
7. перед выводом запроса имени пользователя в консоли оба монитора выводят "нет сигнала", как и прежде.

mkinitcpio запускал

у меня есть одна догадка.
- когда подключён один монитор, прямо перед выводом запроса имени пользователя разрешение экрана меняется
- когда подключено два монитора, в этот же самый момент изображение пропадает.
- изменение разрешения в kernel mode по факту меняет его только на раннем этапе загрузки, потом, когда выводится запрос имени пользователя оно снова становится как обычно

следовательно, где-то есть код, отвечающий за изменение kernel mode в последний этап загрузки, прямо перед запросом имени пользователя. где это прописано?
alfanobot
иксы не запускаются
Они работали когда кмс еще и в помине не было. Настраивать надо.

https://wiki.archlinux.org/index.php/Multihead#RandR

Еще попробовать
https://wiki.archlinux.org/index.php/ATI#Black_screen_and_no_console,_but_X_works_in_KMS
vs220, сейчас мой xorg.conf выглядит так, и я получаю эту ошибку
alfanobot, рекомендую собрать как можно больше информации - без нее одни гадания.
Можно начать с увеличения логирования, например,
- для начала загрузиться с параметром debug
- далее увеличь логирование drm, например, загрузись с параметрами drm.debug=0x1e log_buf_len=1M (строк будет несколько тысяч, смотри внимательнее)

Можно также посмотреть не пустой ли файл /sys/class/drm/card0/error ... В принципе в этой директории можно покапаться и до и после ввода пароля ...
Это то, что первое пришло в голову, при желании можно пробовать и более сложные методы отладки.

EDIT 1 - в качестве примера привожу количество строк, в которых имеется слово drm без отладки и с отладкой
journalctl -b -1 | grep drm | wc -l
7
journalctl -b | grep drm | wc -l
4915
dmesg | grep drm | wc -l
2967

Это, конечно, не факт, что так можно отловить ошибки, но попробовать стоит.

EDIT 2 - можно использовать ступенчатую загрузку: emergency (аварийный режим) -- rescue (режим восстановления) -- default (обычный режим)
После каждого останова смотреть логи и другую нужную информацию
... из режима emergency для продолжения загрузки в режим восстановления использовать команду systemctl rescue, и из режима восстановления для продолжения загрузки (чтобы загрузиться в обычный режим) нажимаем Ctrl+D ...
Ошибки не исчезают с опытом - они просто умнеют
alfanobot
vs220, сейчас мой xorg.conf выглядит так, и я получаю эту ошибку

Для начала попробуйте с кмс без nomodesetting добавив в параметры ядра fbcon=map:1 или fbcon=map:0
https://wiki.archlinux.org/index.php/ATI#Black_screen_and_no_console,_but_X_works_in_KMS

не поможет попробовать задать в параметрах ядра видеовывод video=<conn>:<xres>x<yres>[M][R][-<bpp>][@<refresh>][m][eDd]
https://wiki.archlinux.org/index.php/Kernel_mode_setting#Forcing_modes

Если и это не даст результата то уже с nomodesetting настраивать правильно xorg.conf
попробуйте сравнить с автоматической конфигурацией когда загрузились с кмс и подключили второй монитор
sudo Xorg :2 -configure
sudo cat /root/xorg.conf.new
Screen 0 здесь лишний по-моему

Section "Device"
Identifier "Radeon"
Driver "radeon"
BusID "PCI:0:1:0"
Screen 0
Option "Monitor-DVI-0" "DVI-0"
Option "Monitor-VGA-0" "VGA-0"
EndSection
 
Зарегистрироваться или войдите чтобы оставить сообщение.