[РЕШЕНО]Установка Archlinux UEFI без Grub

MamkinHaker
Но после установки окружения нюанс. sddm запустилось, ввожу пароль, на секунду показывает экран консоли tty1,возвращает снова в sddm, там уже пустое поле пароля, ввожу пароль и тоже самое по кругу бесконечно. Чего-то не хватает в иксах? Читал где-то, что есть ещё баг такой у sddm.
Иксы имхо лучше отладить до установки DM через startx запуская.
MamkinHaker
Были косяки во время установки, не примонтировался sda1
Вот уже начали ловить грабли с отдельным /boot - а оно вам надо, лишняя секунда при загрузке того стоит?
vs220
Вот уже начали ловить грабли с отдельным /boot
Согласно вики для UEFI нужен основной раздел в FAT.
И флагом esp.
beisic
Согласно вики для UEFI нужен основной раздел в FAT
Это совсем не означает что надо туда пихать /boot.

Полностью поддерживаю, разве что исошку лайва еще можно положить
nafanja
efi раздел не предназначен для ядер, а только для загрузчиков!!!
Mirk
касательно ssdm, я бы посоветовал выбросил его, слишком бажный.
Пользуюсь 4 года, что-то не заметил багов.
RusWolf, имею другую информацию, основанную не только на моём опыте использования. Lxdm посоветован по тому же принципу.
Mirk
Lxdm посоветован по тому же принципу.
соответственно они равно бажные )))
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
beisic
Делайте по Wiki :
Учту, не смотрел это.

С initrd /amd-ucode.img система не стартует, жалуется на него и выделяет красным цветом. Закомментировал и стартанула.
Вот уже начали ловить грабли с отдельным /boot - а оно вам надо, лишняя секунда при загрузке того стоит?
Бут же вроде я сделал на ехt4, в корне сда2, /boot/efi/EFI и уже там ядра загрузчик vm и ucode и прочее. Или нет?
Хотя я вначале хотел чтоб всё это было по современному, на сда1 , но этот эксперимент решил отложить на неопределённое будущее.
Или как это не раздельно?

Еще при настройке загрузчика писало что то про рандом, типо лоадер буде лежать в случайном месте. Это как так? Или это мой вольный перевод без знания английского так исковеркал смысл?
MamkinHaker
С initrd /amd-ucode.img система не стартует, жалуется на него и выделяет красным цветом. Закомментировал и стартанула.
Если установили amd-ucode и "разместили" по Wiki , то проблем не должно быть.
MamkinHaker
Еще при настройке загрузчика писало что то про рандом, типо лоадер буде лежать в случайном месте.
Посмотрите, может что с PARTUUID, не перепутали с UUID :
ls -l /dev/disk/by-partuuid/ 
См.Постоянное именование блочных устройств
beisic
Посмотрите, может что с PARTUUID, не перепутали с UUID :
Нет не перепутал.
 
Зарегистрироваться или войдите чтобы оставить сообщение.