Поддержка
tcp_wrappers
удалена из всех пакетов, а сам пакет удален из
[core]
. Это связано с разработчиками, не выпускавшими новую версию с апреля 1997 года. Кроме того, новые демоны и приложения поддерживают libwrap непоследовательно, что приводит к путанице относительно того, поддерживает ли приложение данную библиотеку.
Если вы уже используете
/etc/hosts.allow
или
/etc/hosts.deny
для безопасности или с целью записи в журнал, то для этих задач вам необходимо настроить соответствующим образом и использовать другой инструмент, такой как
iptables
.

Оригинал новости: Dropping tcp_wrappers support
Автор: Dan McGee
Дата публикации: 16-07-2011
Обновлённая версия ardour не будет иметь поддержки модулей LV2 из-за удаления slv2 из его зависимостей. Это является результатом API/ABI-несовместимости между последними версиями из набора Redland/Rasqal/Raptor, который мы предоставляем, и внутренней поддержкой в Ardour версий этих библиотек, от которых зависит SLV2. Также такая систуация является первопричиной сбоев при сборке программ и появления ошибки сегментации (build failures and runtime segmentation fault), которые вы, возможно, испытали.
Разработчик не будет заниматься обновлением своих исходных кодов (Upstream will not be updating its codebase), поскольку все усилия сосредоточены на третьей версии DAW, которая вообще покончит с SLV2 (и, может быть, в целом официально примет другие реализации стандарта LV2). В настоящее время никто не предоставляет патч для решения этой проблемы. В данном случае, совместимость пакетов не представляется возможной, поэтому мы решили отказаться от поддержки LV2 со стороны нашего пакета Ardour. Пользователи могут по-прежнему использовать модули LADSPA, или же, что, вероятно, является более популярной технологией, перейти к другим LV2-хостам с помощью jack и его потоковых возможностей.

Источник: Ardour loses LV2 support
Автор: Ray Rashif
Дата публикации: 08.07.2011
Из-за ошибки в системе разрешения конфликтов, обновление пакета, в прошлом называвшегося zope-interface, потребует некоторых телодвижений:
pacman -Rdd zope-interface
pacman -S python2-zope-interface --asdeps
Присоединяйтесь к нам на канале #archlinux-bugs во Freenode в эту субботу, 18-го июня и помогите нам закрыть некоторые баги!

Источник: News: Bug Day: Saturday, June 18
Автор: Evangelos Foutras
Дата публикации: 15.06.2011
Присоединяйтесь к нам на Freenode, канал #archlinux-bugs в эту суююоту 18-го июня и помогите нам закрыть некоторые баги!

Оригинал:
В апреле этого года мы отметили десятую годовщину последнего релиза net-tools. Мы решили посмотреть на это как на возможность объявить net-tools устаревшими и обеспечивать альтернативные и лучше поддерживаемые решения для подобной функциональности. Это влечет за собой несколько последствий, но большинство людей не должны их заметить.

Пакет net-tools будет по-прежнему оставаться в репозиториях, поэтому скрипты, основанные на них, должны и далее работать.

rc.conf
В
rc.conf
введен новый синтаксис для простой настройки сети с помощью
iproute2
, а не net-tools. Прежняя функциональность до сих пор сохранена для тех, кто предпочитает оставаться с этими инструментами (net-tools), но не надейтесь получить новые возможности.

Новый синтаксис очень упрощен и поддерживает только лишь одно устройство проводной сети (настроенное статически или через dhcp), и мы не планируем добавлять новые функции в будущем. Мы стремимся поощрять использование более современных сетевых решений, таких как
networkmanager
или наш собственный
netcfg
.

domainname
(a.k.a.
nisdomainname
, a.k.a
ypdomainname
)
Эти бинарники в настоящее время предоставляются
yp-tools
, а не
net-tools
. К тому же доменное имя более не устанавливается initscripts, наоборот, с ним имеет дело исключительно ypbind rc script.

До этого изменения доменное имя обрабатывалось непоследовательно, иногда считываясь из
/etc/conf.d/nisdomainname
, а иногда из
/etc/defaultdomain
. С этого времени доменное имя считывается только из
/etc/conf.d/nisdomainname
.

hostname
Этот бинарник теперь предоставляется
coreutils
, а не
net-tools
.

Оригинал: News: Deprecation of net-tools
Оригинал: Tom Gundersen
Дата публикации: 08.06.2011
С незапамятных времен мы использовали в наших доморощенных системах “черный список” для блокировки модулей ядра черный список (в различных воплощениях). Он верно служит нам, но мы (или, скорее, наши upstream-разработчки) уже достигли поворотного пункта, где такой список более не требуется.

Поэтому мы приняли решение избавиться от всей логики “черного списка” модулей и рассчитывать только на “черный список”, представляемый
modprobe
. Это означает изменения в синтаксисе, а также небольшие изменения в функциональности. Мы надеемся, что кратковременные неудобства оправдаются выгодами в долгосрочной перспективе.

Из-за не связанных (с этим) изменений в нашем пакете udev, мы более не загружаем так много модулей, как мы ранее привыкли делать по умолчанию, поэтому некоторые проблемные модули (например,
pcspkr
and
snd-seq-oss
), возможно, больше не нужно помещать в “черный список”.


Различное представление “черных списков”
Представления о блокировке модулей, которое мы использовали ранее (к сожалению) немного отличается от того, что принято для modprobe.

  • наш “черный список”: блокируемый модуль, или модуль, который зависит от него, никогда не будет загружаться автоматически udev, но может быть загружен вручную.
  • “черный список” modprobe: блокируемый модуль не будет загружен автоматически, но могут быть загружены, если другой не-блокируемый модуль зависит от него, или если он загружен вручную.
  • отключение модуля: можно получить то же поведение, которого мы добивались, заставляя модуль всегда быть не в состоянии загрузиться, но будет невозможно загрузить его вручную.

Блокирование или отключение модулей при загрузке (boot time)
Модули могут быть блокированы во время загрузки путем добавления
modprobe.blacklist=mod1,mod2,mod3
к командной строке ядра (в grub, lilo или syslinux). В качестве варианта, модули могут быть отключены напрочь путем добавления взамен указанного выше
mod1.disable=1 mod2.disable=1 mod3.disable=1
. Это полезно в чрезвычайной ситуации, когда поломанный модуль делает невозможным загрузку системы.

Постоянное блокирование или отключение
Вместо того, чтобы блокировать модули через “черный список” в
rc.conf
, используйте родные конфигурационные файлы modprobe. Они могут быть найдены в /etc/modprobe.d/, и документированы в
man modprobe.d
.

Замена находящейся в
rc.d
строке
MODULES=(!mod1 !mod2 !mod3)
заключается в добавлении файла
.conf
в
/etc/modprobe.d/
следующего содержания:

blacklist mod1
blacklist mod2
blacklist mod3

Кроме того, для чтобы модули никогда не добавлялись, даже если они необходимы другими модулями загрузки:

install mod1 /bin/false
install mod2 /bin/false
install mod3 /bin/false

Оригинал: News: Changes to module blacklisting
Автор: Tom Gundersen
Дата публикации: 08.06.2011
Из-за конфликта имён с другим пакетом решено переименовать скрипт /sbin/rc в /sbin/rc.d.
Переименование не помешает скрипту rc.d как и прежде запускать и останавливать отдельных демонов, а так же просматривать статус всех демонов в системе.
Новые возможности:

Скрипт /sbin/rc для запуска, останова и вывода списка демонов.
Поддержка FakeRAID (dmraid).
Поддержка btrfs.

Функциональные изменения:

Управление “дрейфом” системного таймера в hwclock перемещено в демон, который не должен использоваться в большинстве случаев, поскольку может привести к трудноуловимым ошибкам (особенно, если используется двойная загрузка или ntp). Если вы понимаете, что делаете, и хотите настроить “дрейф” системных часов, добавьте “hwclock” в массив DAEMONS.
Теперь udev управляет mdadm, поэтому mdadm больше не вызывается явно. Это должно повысить надежность без потери функциональности.

Рекомендации:

Напоминаем, что initscripts предполагают обновления всех остальных пакетов (исключение - ядро). В особенности это касается udev, mdadm, dmraid и lvm.
Теперь мы настоятельно рекомендуем не использовать HARDWARECLOCK=“localtime”, потому что это может привести к нескольким известным неустранимым ошибкам. Хотя планов прекращать поддержку “localtime” нет.

Оригинал новости: initscripts update
Пакеты GNOME 3.0.1 перемещены в репозиторий .

Это крупное обновление, поэтому Вы должны обратить внимание на несколько вещей:
GNOME3 заменяет GNOME2.
GNOME3 имеет 2 режима: стандартный режим (gnome-shell) и альтернативный (англ. fallback) режим (gnome-panel + metacity).
Ряд пакетов, такие, как апплеты панели, использующие Bonobo, больше не поддерживаются и будут убраны в ближайшее время.
Теперь требуется pulseaudio для запуска среды GNOME.

Инструкции по обновлению и установке доступны на https://wiki.archlinux.org/index.php/GNOME_3

Лишь о тех ошибках, которые связаны с созданием пакетов, следует сообщать по адресу http://bugs.archlinux.org/.

Об ошибках и пожеланиях относительно новых функций следует сообщать по адресу https://bugzilla.gnome.org/.

Оригинал новости: GNOME3 in
Пакеты драйверов nvidia-173xx и nvidia-96xx были удалены из наших репозиториев, поскольку они несовместимы с новой версией xorg-сервера. Они заработают только после исправлений со стороны компании NVIDIA, чего пока не произошло.
Для большинства видеокарт лучшей альтернативой является xf86-video-nouveau (см.: https://wiki.archlinux.org/index.php/Nouveau).
Так же, можно воспользоваться xf86-video-nv или xf86-video-vesa. Удаляем старые драйвера nvidia, устанавливаем вышеупомянутые пакеты, и сервер xorg при запуске автоматически выберет наиболее подходящий вариант.
Пакеты GNOME 3.0.0 доступны в репозитории . Они идут вместе с обновлением gtk2, а так же содержат новый gtk3.

Это крупное обновление и вы должны обратить внимание на несколько вещей:
GNOME3 заменит GNOME2, когда перейдет в .
GNOME3 имеет 2 режима: “стандартный” режим (gnome-shell) и “резервный” режим (gnome-panel + metacity).
Апплеты панели, использующие Bonobo, больше не поддерживаются и пакеты, зависящие от них, будут убраны.
Теперь для запуска среды GNOME требуется pulseaudio.
Некоторые пакеты существуют для разных версий - для gtk2 и gtk3. Они обычно имеют имя типа “packagename3”. Например, vte3, libwebkit3, gtkhtml4.
pygobject теперь доступен для Python 3 в пакете “py3gobject”.

Приятного тестирования этих пакетов!

Инструкции по обновлению и установке доступны на https://wiki.archlinux.org/index.php/GNOME_3

Ошибки, связанные с созданием пакетов, следует сообщать на http://bugs.archlinux.org/ .

Сбои и пожелания следует сообщать на http://bugs.archlinux.org/ .
Для снижения нагрузки на действующих разработчиков принято решение расширить команду и привлечь желающих заняться следующими проектами:

1) Главный по багам:
Рулить поступающими багами: сортировка, допрос пользователей, открытие апстрим-багрепортов, закрытие багов. Оценка простых патчей, поиск и активизация работ по древним багам.

2) Администратор зеркал:
Следить за запросами на баг-треккере, следить за актульностью контактной информации. Общаться на arch-mirrors. Следить за качеством зеркал, автоматизация процесса контроля качества.

3) Разработчик netcfg:
Исправление багов и внедрение нового функционала. Работа на соответствующем разделе баг-треккера.

4) Разработчик initscripts:
См. п.3

5) Разработчик ABS:
См. п.4 ;)

Заявки отправляйте по адресу applicants@archlinux.org, в тему добавляйте , , , или соответственно. Не забудьте рассказать почему Вы являетесь лучшим кандидатом на запрашиваемую позицию. И всё это на английском языке ;).
В вышеозначенный день на канале #archlinux-bugs будут проходить мероприятия по уменьшению числа открытых багов на баг-треккере. Присоединяйтесь!
Сообщество разработчиков KDE объявило о выходе Software Compilation 4.6. С новшествами Вы можете ознакомиться на их сайте. Как всегда в Арче доступны самые свежие пакеты.

В этом релизе окончательно осуществлён переход на UPower, UDev и UDisks вместо HAL, соответственно пакет hal теперь не является зависимостью для kdebase-workspace и может быть удалён из системы.

KDE PIM 4.6 пока не вышел (но скоро будет), поэтому продолжаем пользоваться версией 4.4.

Разработчики Phonon'а объявили об окончании поддержки Xine, рекомендуется задуматься о переходе на воспроизведение через GStreamer или VLC.

Если после обновления на Вас обрушится вал ошибок попробуйте создать новый аккаунт и/или удалить старые настройки ~/.kde4 /tmp/kde- /var/tmp/kdecache-. Akonadi хранит свои данные в ~/.config/akonadi и ~/.local/share/akonadi.

Следующие пакеты удаляются: kdegames-ksame, kdesdk-kbugbuster, kdeutils-okteta, а эти наоборот появляются: kdeaccessibility-kaccessible, kdegames-klickety, kdesdk-okteta, kdeutils-filelight, kdeplasma-addons-concontainments, kdeplasma-addons-runners-events.
MySQL 5.5 добавлен в . Это крупное обновлении версии 5.1 ранее находившейся в репозитории. Отныне поддержка Archive, Blackhole и Federated engine не включается в пакет, поскольку редко используется.

После обновления пакета MySQL и перезагрузки базы данных, необходимо запустить `mysq_upgrade` для того, чтобы убедиться что таблицы, представления (views) и процедуры обновились для совместимости с MySQL 5.5.

Желательно всегда делать резервную копию баз данных прежде чем производить обновление. Так же понадобится подкорректировать опции в my.cnf, чтобы файл конфигурации был совместим с версией 5.5; Подробности можно узнать здесь (англ. яз.).
Новый пакет syslinux (4.03-4) теперь включает в себя конфигурационный файл, который находится в /boot/syslinux/syslinux.cfg. Если возникает конфликт файлов во время обновления, выполни:

mv /boot/syslinux/syslinux.cfg /boot/syslinux/syslinux.cfg.sav
pacman -S syslinux
mv /boot/syslinux/syslinux.cfg.sav /boot/syslinux/syslinux.cfg
Обновление glibc-2.12.2-1 увеличивает минимум требуемой версии ядра до 2.6.27. Эта версия ядра была выбрана поскольку это старейшее ядро с долгосрочной поддержкой. Пользователи пакетов “kernel26” и “kernel26-lts” не подвержены этим изменениям.

Тем, кто хочет продолжать использовать более старые версии ядер, будет необходимо пересобрать пакет glibc, внеся необходимые корректировки в опцию “–enable-kernel”.

Оригинал новости: Minimum required kernel version increased от Allan McRae
Дата оригинальной новости: 28 декабря 2010 г.
Крупное обновление python переезжает из и скоро окажется на вашем любимом зеркале. Пакет под названием “python” теперь соответствует 3-й версии языка, тогда как 2-я версия поддерживается пакетом “python2”.
Так как /usr/bin/python теперь указывает на бинарник 3-й версии, то могут возникнуть проблемы для программ, требующих 2-ю версию. Для них необходима ссылка на /usr/bin/python2. Все пакеты из официальных репозиториев были соответствующим образом обновлены. Тем не менее, при обнаружении проблем без стеснения сообщайте на баг-треккер.
Пакеты из AUR, как и любый другие сторонние проекты, с большой вероятностью потребуют ручного вмешательства, так как многие программы до сих пор несовместимы с Python 3.
С недавнего времени начался регулярный опрос всех официальных зеркал и сбор статистики такой как доступность, задержка синхронизации и проч. Информация доступна на новой странице статуса зеркал. Там же можно найти описание методики опроса и расшифровку представленных параметров.
В добавок, появилась возможность создать свой собственный список зеркал, отсортированный с использованием статуса зеркал.