Установка ArchLinux в Virtual Box

Спасибо большое!
tuchin
Я и использую cfdisk
предлагаю почитать мои темы на этом форуме.
я уже наступил на все или почти все грабли до тебя вас

если одно ядро+fallback, то 200мб ext4 для /boot достаточно
пробовал с syslinux
С уважением, .
Bendalf
/boot должен быть 250 мб или больше. иначе не влезет ядро
250 мб - это мало, ведь по-хорошему там должно храниться и второе ядро, LTS например, чтобы можно было загрузиться в случае если накосячили в текущей сборке основного ядра. Например, у меня сейчас в /boot 175 Мб, то есть на второе ядро просто не хватит. А ставить второе ядро - НАДО, я в этом убедился не раз и не пять. Вот 500 Мб - это самый раз. Хотя лично я даю 1 Гб, у меня SSD большие.
А что делать, если сначала установил Windows 10 или Windows 11 и очень нужно, чтобы на ПК были Windows и Linux? При стандартной установке Windows ведь нет возможности задать размер раздела EFI? В менеджере дисков Windows я не нашел возможности увеличить размер раздела EFI. В вики арч я читал о размере EFI в 1 Гб, но мне нужно, чтобы было две ОС, одна из которых - Windows.
tuchin
А что делать, если сначала установил Windows 10 или Windows 11 и очень нужно, чтобы на ПК были Windows и Linux?
Использовать grub2 и не выносить /boot на ESP раздел.
https://t.me/arch_linuxru
Спасибо за ответ. Нужно создать в /mnt просто директорию boot и в нее не монтировать ESP-раздел Windows? А куда монтировать ESP раздел? Какие команды нужно давать для установки grun? Поделитесь, пожалуйста, ссылкой на подробное описание такой возможности.
tuchin
А куда монтировать ESP раздел?
Если использовать grub2, то точка монтирования при установке арча, /mnt/boot/efi

tuchin
Какие команды нужно давать для установки grun?
При использование точки монтирования ESP раздела, как /mnt/boot/efi, достаточно двух команда:
grub-install
grub-mkconfig -o /boot/grub/grub.cfg
https://t.me/arch_linuxru
Когда я монтировал в /mnt/boot, появлялось сообщение о нехватке места, а когда смонтировал позавчера в /mnt/boot/EFI (у меня было EFI большими буквами, не знаю, важно ли это) - такого сообщения не возникало. Не очень понятно, почему так происходит. Ведь efi в директории boot, а в этой директории не было места. Поясните, пожалуйста.
tuchin
Поясните, пожалуйста.
Да я вроде уже пояснял
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE
Вы мне посоветовали создать каталог /boot/EFI, все установилось, но мне не понятно, почему при монтировании ESP раздела просто в boot происходит нехватка места, а при монтировании в поддиректорию mnt заполненной директории все монтируется без ошибок. Из-за того, что файлы загрузчика и ESP раздела теперь распределяются по разным директориям (загрузчик в /boot, а ESP раздел в /boot/mnt)?
 
Зарегистрироваться или войдите чтобы оставить сообщение.