Отваливаются bluetooth наушники при смене tty

В tty7 (основной раб.стол) bluetooth наушники подключаются и работают нормально. Но как только перехожу в tty1 (при запуске игрушки) - звук переключается на монитор (hdmi)... Возвращаюсь в tty7 - звук переходит в наушники. До этого много лет сидел на Ubuntu - там таких проблем не было. Как пофиксить?
Ryzen5600/A520M/16Gb/NVMe500Gb/RX6600m/XFCE/6.7.0-arch3-1
В tty1 какой юзер , тот же что и в tty7 ? Вывод игрушки так же настроен на наушники?
user в системе всего один... вывод в игрушке не настаивается - она использует что предлагает система..
Игрушка ни при чём - можно просто переключить на люболй tty с запросом логина (отличный от tty7) и наушники моментально дисконектятся, если в течение нескольких секунд вернуться в tty7, то законектятся обратно, если дольше, то уже нет...
Ryzen5600/A520M/16Gb/NVMe500Gb/RX6600m/XFCE/6.7.0-arch3-1
Вывод настраивается в системе звука для игрушки а не в игрушке, что у вас в качестве звукового сервера и какое DE
pipewire
XFCE
Ryzen5600/A520M/16Gb/NVMe500Gb/RX6600m/XFCE/6.7.0-arch3-1
Запустите pavucontrol при запущенной игрушке и настройте вывод ее на наушники, возможно надо будет ещё добавить в ~/.bash_profile или стартовый скрипт игрушки команду
https://wiki.archlinux.org/title/PipeWire#Sound_does_not_automatically_switch_to_Bluetooth_headphones
Возможно Вы меня неправильно поняли - проблема не в том, что игрушка выводит звук не на то устройство, а в том. что само устройство (bluetooth гарнитура) мгновенно отключается как только меняется tty7 на любой другой tty.
Ryzen5600/A520M/16Gb/NVMe500Gb/RX6600m/XFCE/6.7.0-arch3-1
vovchok
как только меняется tty7 на любой другой tty.
при переходе и логине выполните
pactl load-module module-switch-on-connect
если не поможет
wpctl set-default <id ваших наушников из wpctl status>
и проверьте что юзер в группах audio и lp
groups
log games cups sambashare realtime users video storage lp disk share audio
если я правильно понял про <id ваших наушников из wpctl status>
Settings
 └─ Default Configured Node Names:
         0. Audio/Sink    bluez_output.C0_DC_DA_F5_5B_E2.1
то не помогает...
startx ~/games/stalker.sh -- :1
#!/bin/bash
pactl load-module module-switch-on-connect
pctl set-default bluez_output.C0_DC_DA_F5_5B_E2.1
cd ~/games/OP-2.2
wine ./bin/XR_3DA.exe -nointro

А как оно реализовано в убунте, что там такой проблемы совсем нет?
Наушников этих у меня много и прописывать каждые как-то уж слишком...
Или эти заморочки от Pipewire а в PulseAudio их нет?
Ryzen5600/A520M/16Gb/NVMe500Gb/RX6600m/XFCE/6.7.0-arch3-1
 
Зарегистрироваться или войдите чтобы оставить сообщение.