Какой ставить пакет для поддержки php7.5?

phpmyadmin требует версию:

PHP 7.2.5+ is required.
Currently installed version is: ' . PHP_VERSION . '
Попытался ствить пакет из аур php72 но при сборке вылетает с ошибкой

make: *** [Makefile:317: test] Error 1
==> ERROR: A failure occurred in check().
    Aborting...
ivan10
Попытался ствить пакет из аур php72 но при сборке вылетает с ошибкой
Попробуй php74
ivan10
PHP 7.2.5+ is required.
+ значит не ниже. В стандартных репозиториях версия 8.9.2
покажите
php -v
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE
alien175
ivan10
PHP 7.2.5+ is required.
+ значит не ниже. В стандартных репозиториях версия 8.9.2
покажите
php -v
не, не 8.9.2

# php -v
PHP 8.2.9 (cli) (built: Aug 13 2023 06:12:43) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.2.9, Copyright (c) Zend Technologies
sudo pacman -S phpmyadmin
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE
ivan10
не, не 8.9.2
Опечатался(
🖥 AsRock B550M Pro4 :: AMD Ryzen 5 3600 :: 16 GB DDR4 :: AMD Radeon RX 6600 :: XFCE
💻 ACER 5750G :: Intel Core i5-2450M :: 6 GB DDR3 :: GeForce GT 630M :: XFCE
RusWolf
ivan10
Попытался ствить пакет из аур php72 но при сборке вылетает с ошибкой
Попробуй php74
не таже ошибка при сборке;

Dereferencing expression parentheses [Zend/tests/varSyntax/parenthesesDeref.phpt]
WeakReference [Zend/tests/weakrefs/weakrefs_001.phpt]
Cannot take property of a string [Zend/tests/varSyntax/propertyOfStringError.phpt]
WeakReference serials [Zend/tests/weakrefs/weakrefs_002.phpt]
Static member access [Zend/tests/varSyntax/staticMember.phpt]
WeakReference object handlers [Zend/tests/weakrefs/weakrefs_003.phpt]
WeakReference no inheritance [Zend/tests/weakrefs/weakrefs_004.phpt]
WeakReference no __construct [Zend/tests/weakrefs/weakrefs_005.phpt]
Using return of property assignment to reference that destroys object [Zend/tests/write_property_ref_overwrite_return.phpt]
=====================================================================
make: *** [Makefile:310: test] Error 1
==> ERROR: A failure occurred in check().
    Aborting...

alien175
sudo pacman -S phpmyadmin
Сервак недавно установил, видел настройки для phpmyadmin нужно подключать php7.5 модули в настройках, но не найти пакеты старой версии php
ivan10
не таже ошибка при сборке;

Всё нормально собирается, на арче.
 
Зарегистрироваться или войдите чтобы оставить сообщение.