[РЕШЕНО] Проблема с обновлением из-за недействительной подписи.

indeviral
Какая у вас конкретно ошибка сейчас?

sudo pacman -Syu

ошибка: ошибка GPGME: Нет данных
:: Обновление баз данных пакетов...
 core                      19,8 KiB  43,3 KiB/s 00:00 [############################] 100%
 extra is up to date
 community is up to date
 multilib is up to date
 blackarch is up to date
ошибка: ошибка GPGME: Нет данных
ошибка: failed to synchronize all databases (непредвиденная ошибка)
I learn Linux...)))
# pacman -S archlinux-keyring
Ошибки в тексте-неповторимый стиль автора©
indeviral
# pacman -S archlinux-keyring


sudo pacman -S archlinux-keyring


ошибка: ошибка GPGME: Нет данных
ошибка: база данных 'core' недействительна или повреждена (неверная или поврежденная база данных(PGP-подпись))
I learn Linux...)))
art896
ошибка: failed to synchronize all databases (непредвиденная ошибка)
Во первых у тебя заблокирована база данных пакетов, то есть в системе присуствует файл /var/lib/pacman/db.lck
Его нужно удалить и далее повторить sudo pacman -Syu .... и смотреть какие там снова будут ошибки.
Ошибки не исчезают с опытом - они просто умнеют
indeviral
# pacman -S archlinux-keyring

sudo pacman -S archlinux-keyring

ошибка: не удалось открыть файл /var/lib/pacman/sync/core.db: Unrecognized archive format
ошибка: не удалось открыть файл /var/lib/pacman/sync/extra.db: Unrecognized archive format
ошибка: не удалось открыть файл /var/lib/pacman/sync/community.db: Unrecognized archive format
ошибка: не удалось открыть файл /var/lib/pacman/sync/multilib.db: Unrecognized archive format
ошибка: не найдена цель: archlinux-keyring

Такой вывод, если убрать проверку подписи пакетов в pacman.conf

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Never
#Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required
I learn Linux...)))
Ну значит, у вас пакет не совсем такой как у нас, а может вы не обновляли давно.
Тогда нужно удалить то что вы там насоздавали
# rm -R /etc/pacman.d/gnupg
Потом в ручную проинициализировать базу
# pacman-key --init
и потом уже
# pacman -S archlinux-keyring
если нет то тогда, нужно написать что-то типа такого:
pacman-key --populate archlinux blackarch
p.s. и да vasek прав ещё и с сама база ушатана
Ошибки в тексте-неповторимый стиль автора©
vasek
art896
ошибка: failed to synchronize all databases (непредвиденная ошибка)
Во первых у тебя заблокирована база данных пакетов, то есть в системе присуствует файл /var/lib/pacman/db.lck
Его нужно удалить и далее повторить sudo pacman -Syu …. и смотреть какие там снова будут ошибки.

sudo rm -r /var/lib/pacman/db.lck
rm: невозможно удалить '/var/lib/pacman/db.lck': Нет такого файла или каталога

Странности...
I learn Linux...)))
потому что она "ушатана" а не заблокирована)
# rm -rf /var/lib/pacman/sync/
Ошибки в тексте-неповторимый стиль автора©
indeviral
rm -rf /var/lib/pacman/sync/
sudo pacman -Syu


:: Обновление баз данных пакетов...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 blackarch is up to date
:: Запускается полное обновление системы...
ошибка: не удалось открыть файл /var/lib/pacman/sync/core.db: Unrecognized archive format
ошибка: не удалось открыть файл /var/lib/pacman/sync/extra.db: Unrecognized archive format
ошибка: не удалось открыть файл /var/lib/pacman/sync/community.db: Unrecognized archive format
ошибка: не удалось открыть файл /var/lib/pacman/sync/multilib.db: Unrecognized archive format

предупреждение: python-sphinx-autobuild: установленная версия (2021.03.14-1) новее, чем в blackarch (0.7.1-4)
предупреждение: python-whichcraft: установленная версия (0.6.1-5) новее, чем в blackarch (0.6.1-4)
:: Заменить reaver на blackarch/reaver-wps-fork-t6x? [Y/n]
I learn Linux...)))
Вам не надо обновлять всё. Обновите для начала pacman и keyring
И для начала запустите
# pacman -Sy
потому-что если ошибки сразу при синхронизации то сначала из надо разобрать.

p.s. покажите ещё
$ pacman --version
Ошибки в тексте-неповторимый стиль автора©
 
Зарегистрироваться или войдите чтобы оставить сообщение.