Сломался python 3

Добрый день! Подскажите, пожалуйста, нужно срочно!

$ pip3 list
Traceback (most recent call last):
  File "/usr/bin/pip3", line 7, in <module>
    from pip._internal.cli.main import main
ModuleNotFoundError: No module named 'pip._internal.cli.main'

Вот что в /usr/bin/pip3:

#!/bin/sh
'''exec' "/usr/bin/python3" "$0" "[email protected]"
' '''
#-*- coding: utf-8 -*-
import re
import sys
from pip._internal.cli.main import main
if __name__ == '__main__':
    sys.argv[0] = re.sub(r'(-script\.pyw|\.exe)?$', '', sys.argv[0])
    sys.exit(main())
_maks_
/usr/bin/pip3
Показывайте
pacman -Qo  /usr/bin/pip3
pacman -Qs python-pip

У вас скорее всего не арчевский пакет или не обновили
vs220
Показывайте
> $ pacman -Qo  /usr/bin/pip3
/usr/bin/pip3 принадлежит python-pip 20.1.1-1

[email protected] ~                                                     [12:02:03]
> $ pacman -Qs python-pip
local/python-pip 20.1.1-1
    The PyPA recommended tool for installing Python packages
local/python-pipenv 2020.11.4-1
    Sacred Marriage of Pipfile, Pip, & Virtualenv.
_maks_
python-pip 20.1.1-1
В арче python-pip 20.2.3-1 или не обновили или не арчевский пакет
Если арч - просто обновитесь.
Если нет - смотрите соответствие и версии пакетов своего дистра

Если проблемы с обновлением на арче , проверьте репы на актуальность или новый лист сгенерируйте и пропишите
https://archlinux.org/mirrorlist/
vs220
Если арч - просто обновитесь.
А вот тут вот будут проблемы....
У меня сломаны еще и ключи... Сейчас поставлю, как закончит, покажу вывод
_maks_
сломаны еще и ключи
https://wiki.archlinux.org/index.php/Pacman/Package_signing#Troubleshooting
и темы на форуме можете глянуть например
https://archlinux.org.ru/forum/topic/19958/?page=1
vs220
Если арч - просто обновитесь.
Вот куски:

 $ sudo pacman -Suy
[sudo] пароль для maks:
:: Обновление баз данных пакетов...
 core                  133,7 KiB  1378 KiB/s 00:00 [######################] 100%
 extra                1639,2 KiB  2,17 MiB/s 00:01 [######################] 100%
 community               5,3 MiB  2,71 MiB/s 00:02 [######################] 100%
 archlinuxfr не устарел
 multilib              152,1 KiB  3,16 MiB/s 00:00 [######################] 100%
 archlinuxcn          1468,1 KiB  4,27 MiB/s 00:00 [######################] 100%
:: Запускается полное обновление системы...
:: Заменить xorg-server-xwayland на extra/xorg-xwayland? [Y/n] y
разрешение зависимостей...
проверка конфликтов...
предупреждение: обнаружена циклическая зависимость:
предупреждение: smbclient будет установлен перед cifs-utils, как зависимость

Пакеты (541) accerciser-3.38.0-2
             adobe-source-code-pro-fonts-2.032ro+1.052it+1.012var-1
             alsa-card-profiles-14.0-1  alsi-0.4.9-1  aom-2.0.1-1
             apparmor-3.0.1-1  arandr-0.1.10-5
             archlinux-appstream-data-20201223-1  archlinux-keyring-202012

В КОНЦЕ:

 xf86-video-qxl-0...   109,6 KiB  2,14 MiB/s 00:00 [######################] 100%
 inxi-3.2.01.1-2-any   211,5 KiB  1131 KiB/s 00:00 [######################] 100%
 pamac-aur-10.0.2...   845,7 KiB  4,28 MiB/s 00:00 [######################] 100%
 pikaur-1.6.15-1-any   212,5 KiB  3,92 MiB/s 00:00 [######################] 100%
 polybar-3.5.3-1-...  1025,6 KiB  4,84 MiB/s 00:00 [######################] 100%
 pycharm-professi...   427,1 MiB  10,6 MiB/s 00:40 [######################] 100%
 teamviewer-15.13...    16,9 MiB  9,82 MiB/s 00:02 [######################] 100%
(540/540) проверка ключей                          [######################] 100%
(540/540) проверка целостности пакета              [######################] 100%
ошибка: alsi: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/alsi-0.4.9-1-any.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: drawio-desktop-bin: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/drawio-desktop-bin-13.9.9-1-x86_64.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: gconf: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/gconf-3.2.6+11+g07808097-10-x86_64.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: google-chrome: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/google-chrome-87.0.4280.88-1-x86_64.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: inxi: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/inxi-3.2.01.1-2-any.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: pamac-aur: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/pamac-aur-10.0.2-1-x86_64.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: pikaur: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/pikaur-1.6.15-1-any.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: polybar: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/polybar-3.5.3-1-x86_64.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: pycharm-professional: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/pycharm-professional-2020.3.1-2-x86_64.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: teamviewer: signature from "lilac (build machine) <[email protected]>" is unknown trust
:: Файл /var/cache/pacman/pkg/teamviewer-15.13.6-1-x86_64.pkg.tar.zst поврежден (неверный или поврежденный пакет(PGP-подпись)).
Хотите его удалить? [Y/n] y
ошибка: не удалось завершить транзакцию (неверный или поврежденный пакет)
Обнаружены ошибки, пакеты не обновлены.

_maks_
archlinuxcn.org
sudo pacman -Syy
sudo pacman-key --refresh-keys
sudo  pacman-key --populate archlinux
sudo pacman -S archlinuxcn-keyring
sudo pacman -Su
?
Ой, будьте осторожны с обновлениями. Как пользователь питоновых программ сразу накладываю эмбарго после мажорных обновлений питона. Вот сейчас 3.8 поднлась до 3.9 и все, я в паузе. По обновлении все начинает ломаться кусками, начиная с делюга и кончая сборкой FreeCad. Соторожничаю со снапшотами корневого раздела и пр., предохраняюсь как могу. В основном таки воздержанием.
wau
По обновлении все начинает ломаться кусками
Ошибки, как правило, когда используется pip для установки модулей/пакетов - нужно, если это возможно, ставить используя pacman.
Ошибки не исчезают с опытом - они просто умнеют
 
Зарегистрироваться или войдите чтобы оставить сообщение.