[РЕШЕНО] URxvt - некорректное отображение символов Unicode

Приветствую всех.
$ locale -a
C
POSIX
en_US.utf8
ru_RU.utf8
$ cat /etc/locale.conf
LANG="en_US.UTF-8"
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
Терминал - rxvt-unicode
Некорректно отображаются unicode символы, а именно oh-my-zsh (зелёный символ)

Помогите, заранее спасибо
sokgo81, уточни о каком символе идет речь? в примере не понятно...
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
sokgo81, уточни о каком символе идет речь? в примере не понятно…
О, первая строка, первый символ, который зелёный )
понял, этот символ показался как изображение замкА.
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
попробуй поменять шрифт в URxvt, на тот, который содержит данный символ.
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
попробуй поменять шрифт в URxvt, на тот, который содержит данный символ.
Пробовал, поставил дефолтный шрифт termite (в termite всё корректно отображается) - бестолку, результат не изменился. Может дело в эмуляторе терминала?
sokgo81
Может дело в эмуляторе терминала?
Настройки покажите, больше похоже на шрифт как nafanja говорил.
cat ~/.Xresources
и если только в приглашении не корректный символ то и
~/.bashrc или что там для zsh ~/.zshrc
vs220
sokgo81
Может дело в эмуляторе терминала?
Настройки покажите, больше похоже на шрифт как nafanja говорил.
cat ~/.Xresources
и если только в приглашении не корректный символ то и
~/.bashrc или что там для zsh ~/.zshrc
Ок
$ cat ~/.Xresources
URxvt.font: xft:Hack:size=9
$ cat ~/.zshrc
export ZSH="/home/whoami/.oh-my-zsh"
export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8

ZSH_THEME="robbyrussell"

plugins=(git)

source $ZSH/oh-my-zsh.sh
(zshrc дефолтный)
sokgo81
zshrc дефолтный
А приглашение( типа PS1='\[\e[0;36m\][\[email protected]\h \W]\$\[\e[0m\] ') у вас где описывается?
Символ не корректный только в приглашении или везде?
vs220
А приглашение( типа PS1='\[\e[0;36m\][\[email protected]\h \W]\$\[\e[0m\] ') у вас где описывается?
$ cat ~/.oh-my-zsh/themes/robbyrussell.zsh-theme
local ret_status="%(?:%{$fg_bold[green]%}➜ :%{$fg_bold[red]%}➜ )"
PROMPT='${ret_status} %{$fg[cyan]%}%c%{$reset_color%} $(git_prompt_info)'

ZSH_THEME_GIT_PROMPT_PREFIX="%{$fg_bold[blue]%}git:(%{$fg[red]%}"
ZSH_THEME_GIT_PROMPT_SUFFIX="%{$reset_color%} "
ZSH_THEME_GIT_PROMPT_DIRTY="%{$fg[blue]%}) %{$fg[yellow]%}✗"
ZSH_THEME_GIT_PROMPT_CLEAN="%{$fg[blue]%})"
vs220
Символ не корректный только в приглашении или везде?
Везде. Только в приглашении он в виде какого-то символа a с ударением, а если просто вставить этот символ как команду, то он отображается в виде вопросительного знака.
 
Зарегистрироваться или войдите чтобы оставить сообщение.