Звук выводится одновременно в наушники и колонки

Если я правильно понимаю, то наушники подлючаются к гнезду на передней панели? Для подключения существует два интерфейса AC-97 и HD-Audio, если уши подключаются по AC-97, то все нормально, воткнул наушники — колонки отключились, если по HD-Audio, то балалайку — будет так как вы описываете. Отключать динамики можно с помощью Gnome-alsamixer-а (ставить в нем галку), смотрите на разъеме который идет с передней панели, на нем должно быть написан тип подключения. Бывает, что этих разъемов два, под оба типа. Еще может оказаться переключатель в биосе. Можно переделать, если дружите с паяльником, вот распайка:
In Tux We Trust
vasek
Прибьешь, а он почти сразу же и перезапустится автоматом.
Я таблетку ссылку от этого давал и оговорился, что раньше работало.

redix
Для подключения существует два интерфейса AC-97 и HD-Audio, если уши подключаются по AC-97, то все нормально, воткнул наушники — колонки отключились, если по HD-Audio, то балалайку — будет так как вы описываете.
Вот об этом я и писал, но: у меня оба вывода в HD-Audio. Уже не помню (а экспериментировать лень) что будет если к передний разъем передавать через AC97, но только если оба выходы в HD-Audio есть возможность программно включать/отключать каждый выход.

Кстати, так я ысче в винде фронтальный разъем и раздолбал: всовывал-высовывал наушники, но колонки при этом не выключались, в любом варианте руками выключал питание.
redix
Отключать динамики можно с помощью Gnome-alsamixer-а (ставить в нем галку),
Да как я там только не крутил. Когда я вставляю наушники и мучу мастер - звук пропадает и в наушниках, и в колонках.
При изминении громкости мастера - меняется и там и там.
Ну если это можно включать/отключать программно, то может можно это сделать используя hda-analyzer?
BoberMod
Когда я вставляю наушники и мучу мастер - звук пропадает и в наушниках
А зачем мутить мастер если там можно мутить каналы по отдельности?
In Tux We Trust
Aivar
Я таблетку ссылку от этого давал и оговорился, что раньше работало.
Не пробовал этот способ - при случае попробую.
BoberMod
Когда я вставляю наушники и мучу мастер - звук пропадает и в наушниках, и в колонках.
Так и должно быть. На то он и Master (общий регулятор).
Таки удалось добиться некоторого результата:

Для мута колонок надо было замутить Front. Громкость в наушниках регулируется через Headphon + Master. При этом в колонках звук остался (но очень тихий). При муте (именно нажатие кнопки Mute) Front - мутится и мастер.
Это в какой-то мере решает проблему, но так извращаться каждый раз, что бы переключить звук из клонок на наушники не очешь хочется, да и звук из колонок хоть и тихий, но слышимый
Пару лет назад мне задарили Санхайзеры, и я столкнулся с тем же самым. Очень не устраивало то, что я не знаю работают колонки или нет, если одел наушники. Я пытался запилить скрипт, и прилепить на него какую нибудь кнопку в панели, а потом подвернулся клиент и наушники поменяли хозяина.
In Tux We Trust
redix
и наушники поменяли хозяина.
Было бы неплохо, только у меня походу проблема не в наушниках, а в материнке :(
 
Зарегистрироваться или войдите чтобы оставить сообщение.