Слетел Grub Windows 7

ambulatur
double commander не видит sda1 , как можно увидеть по скрину выше, а mount /dev/sda1 почему-то не работает
Вот по этому у тебя os-prober не видит Windows7, потому что загрузчик windows был на /dev/sda1.
ambulatur, какой командой ты устанавливал груб? точно!!!
Псевдографический инсталлятор Arch Linux ver. 3.8.2
Благодарности принимаются на ЯД 410012815723874
nafanja
ambulatur, какой командой ты устанавливал груб? точно!!!
pacman -S grub
grub-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
все 3и команды под chroot(до установки de plasma)
Если так нужна винда, я бы не стал гадать, что там, а попробовал бы восстановить виндовый загрузчик и добиться загрузки винды.
А уж после, когда винда нормально загружается, занялся бы linux ...
PS ... судя по ошибкам проблема с виндовым загрузчиком, а возможно и нет - так что проще не гадать, а восстановить его.

В принципе, сначала можно посмотреть, что покажет Super Grub2 Disk - если он покажет твою винду и ты сможешь загрузиться, одна ситуация, если не сможешь, то однозначно нужно восстанавливать виндовый загрузчик.
vasek
В принципе, сначала можно посмотреть, что покажет Super Grub2 Disk - если он покажет твою винду и ты сможешь загрузиться, одна ситуация, если не сможешь, то однозначно нужно восстанавливать виндовый загрузчик.
Super grub видит 4е загрузочных файла на disk C
UEFI-BOOT-REQUIRED:(hd0,msdos2)*
*/efi/boot/bootx64.efi
*/efi/boot/syslinux.efi
*/EFI/boot/bootx64.efi
*/EFI/boot/syslinux.efi
и
archlinux.
А вин7 - не видит.
Наверное нужно ставить live cd win7 и восстанавливать MBR.
ambulatur
А вин7 - не видит.
Наверное нужно ставить live cd win7 и восстанавливать MBR.
Думаю то же самое, что и писал выше - сначала восстанови виндовый загрузчик, чтобы винда нормально загружалась, а уж потом все остальное. Super Grub2 Disk меня еще никогда не обманывал.
PS ... правда у меня нет опыта работы с UEFI - возможны какие нибудь нюансы мне не знакомые. Может подскажут что спецы по UEFI.
vasek
Может подскажут что спецы по UEFI.
Вот не пойму разбивка у него мбр. При чем тут ефи?
ТС не может внятно описать проблему.

Начнем пожалуй с lsblk
Затем покажи список файлов в sda1 и на диске С: (скорее всего sda2)
Lupus pilum mutat, non mentem.
ambulatur
http://i.imgur.com/VwfVQFk.png
Согласно этой картинке, разметка у него MBR DOS
Загрузчик винды был на /dev/sda1

C его же слов, у него ошибки чтения на разделе /dev/sda1
Проще заново восстановить виндовый загрузчик, потом с Live CD или Live USB переустановить и настроить grub2

ambulatur
Наверное нужно ставить live cd win7 и восстанавливать MBR.
Повторю ещё раз если не понял с первого раза, MBR у тебя в порядке, так как разделы не улетели и грузится Grub :)
RusWolf
Повторю ещё раз если не понял с первого раза, MBR у тебя в порядке, так как разделы не улетели и грузится Grub :)
В общем суть уловил, к вечеру поставлю загрузчик win , а за тем с вина поставлю grub и не буду танцевать с бубном.
ambulatur
а за тем с вина поставлю grub и не буду танцевать с бубном.
grub лучше ставить с установочного диска Arch Linux через arch-chroot.
 
Зарегистрироваться или войдите чтобы оставить сообщение.