[РЕШЕНО] подключение плеера sony

Подскажите пожалуйста в каком направлении смотреть. У меня Archlinux ядро 4.8.13-1, настроена служба Udisks, все флешки и дисковые накопители нормально монтируются. Беда с плеером sony nwz-b173f. При подключении он почему то не определяется как устройство по команде ls /dev ничего не меняется. Да еще и сам плеер зависает, приходится перезагрузку делать.
У вас, вероятнее всего, плеер представляет собой MTP устройство. Посмотрите статью в ArchWiki по ссылке.
Согласно соответствующей статье в вики установил пакет libmtp, далее gvfs-mtp (у меня установлен Thunar). После установки пакета gvfs-mtp Thunar стал отображать плеер под именем WALKMAN, но его содержимое не отображает. Теперь при подключении плеера система думает минут 5 далее Thunar выдает ошибку : Не удалось подключить «WALKMAN», не удалось открыть устройство MTP «[usb:002,013]». Команда : sudo blkid -o list -c /dev/null не находит это устройство но не мгоновенно, какое то время происходит поиск. Установка пакета gvfs-gphoto2 для поддержки PTP ничего не изменила, это для другого класса устройств. Команда mtp-connect выдает следующее : libmtp version: 1.1.12 Device 0 (VID=054c and PID=0689) is a Sony NWZ-B173F. далее зависание терминала.
команда lsusb опознает плеер как : Bus 002 Device 029: ID 054c:0689 Sony Corp. Walkman NWZ-B173F
Установил mtpfs, при попытке примонтировать плеер командой mtpfs /mnt/usbstick получаем такое сообщение :
Listing raw device(s)
Device 0 (VID=054c and PID=0689) is a Sony NWZ-B173F.
Found 1 device(s):
Sony: NWZ-B173F (054c:0689) @ bus 2, dev 34
Attempting to connect device
а через 5 минут где то следующее сообщение:
Attempting to connect device
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
inep: usb_get_endpoint_status(): No such device
outep: usb_get_endpoint_status(): No such device
libusb_open() failed!: No such device
LIBMTP PANIC: Could not init USB on second attempt
Unable to open raw device 0
Вопрос закрыт, в системных требованиях к устройству написано что оно поддерживает только IBM PC/AT-совместимый компьютер, на котором установлена одна из следующих операционных систем : Windows, и все. Как это преодолеть на linux я незнаю.
Попробуй ещё это, ради интереса:
https://wiki.archlinux.org/index.php/MTP#Android_File_Transfer
в консоли

https://t.me/atvva
По идее, нужный софт для определения этого плеера как устройства, содержится на нём самом и устанавливается при подключении. Можно попробовать Wine. Или утилиты на его основе. Вдруг получится.
A.T.W.A.
Попробуй ещё это, ради интереса:
https://wiki.archlinux.org/index.php/MTP#Android_File_Transfer
попробовал все что можно из английской версии, в первую очередь настроил /usr/lib/udev/rules.d/51-android.rules с содержимым : SUBSYSTEM=="usb", ATTR{idVendor}=="054c", ATTR{idProduct}=="0689", MODE="0777"
пытался подключится спомощью : simple-mtpfs, jmtpfs, go-mtpfs, mtpfs, aft-mtp-mount. Результат один и тот же - какое то время думает потом вываливается ошибка.
mtp-detect и mtp-connect определяют что это за устройство, как его зовут, а потом тоже самое, что описано выше.

coffeewater
По идее, нужный софт для определения этого плеера как устройства, содержится на нём самом и устанавливается при подключении. Можно попробовать Wine. Или утилиты на его основе. Вдруг получится.
с вайном тоже не получилось - он стал нормально, я установил некоторые приложения для проверки, все работает. Потом перенес в винде с плеера Setup.exe и ini-шки, попробовал запустить в вайне пошла установка потом посыпались ошибки. может быть я просто что-то не так сделал.
вот кусок лога в момент подключения плеера
Jan 19 22:47:43 home-comp kernel: usb 2-3: new high-speed USB device number 15 using ehci-pci
Jan 19 22:47:43 home-comp kernel: usb-storage 2-3:1.0: USB Mass Storage device detected
Jan 19 22:47:43 home-comp kernel: scsi host5: usb-storage 2-3:1.0
Jan 19 22:47:44 home-comp kernel: scsi 5:0:0:0: Direct-Access SONY WALKMAN 1.00 PQ: 0 ANSI: 4
Jan 19 22:47:44 home-comp kernel: sd 5:0:0:0: [sdg] 1878272 2048-byte logical blocks: (3.85 GB/3.58 GiB)
Jan 19 22:47:44 home-comp kernel: sd 5:0:0:0: [sdg] Write Protect is off
Jan 19 22:47:44 home-comp kernel: sd 5:0:0:0: [sdg] Mode Sense: 3e 00 00 00
Jan 19 22:47:44 home-comp kernel: sd 5:0:0:0: [sdg] No Caching mode page found
Jan 19 22:47:44 home-comp kernel: sd 5:0:0:0: [sdg] Assuming drive cache: write through
Jan 19 22:47:44 home-comp kernel: sdg:
Jan 19 22:47:44 home-comp kernel: sd 5:0:0:0: [sdg] Attached SCSI removable disk
Jan 19 22:48:45 home-comp systemd-udevd[235]: seq 2788 '/devices/pci0000:00/0000:00:1d.7/usb2/2-3/2-3:1.0/host5/target5:0:0/5:0:0:0/block/sdg' is taking a long time
Jan 19 22:49:01 home-comp kernel: sd 5:0:0:0: Device offlined - not ready after error recovery
Jan 19 22:50:14 home-comp kernel: sd 5:0:0:0: Device offlined - not ready after error recovery
Jan 19 22:50:27 home-comp kernel: usb 2-3: USB disconnect, device number 15
Jan 19 22:50:27 home-comp kernel: sd 5:0:0:0: [sdg] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x07 driverbyte=0x00
но самое плохое то что сам плеер при каждом подключении немедленно зависает (не реагирует на нажатие кнопок), подзарядка тоже не происходит, приходиться каждый раз тыкать резет, боюсь угроблю так девайс, возможно он не поддерживает просто протокол MTP, или бракованный, хотя пашет нормально
вот здесь нарыл упоминание про мой плеер но толком там ничего не посоветовали
 
Зарегистрироваться или войдите чтобы оставить сообщение.