[РЕШЕНО] Не устанавливается kodi-platform-git

[thenovalive@hp_pavilion_g6 ~]$ yaourt -S kodi-platform-git

==> Загрузка PKGBUILD kodi-platform-git из AUR...
x .SRCINFO
x PKGBUILD
Bevan commented on 2016-01-14 14:45
@TheSaint: Do you use the latest version of this PKGBUILD or did you modify it by any way? It should use a git revision which does not look for p8-platform. Also see the comments below.

zman0900 commented on 2016-02-23 21:02
Since kodi v16 package is available, can the default API for this package change to 16?

kevku commented on 2016-10-16 06:52
API=17

17)  depends+=('p8-platform') # or  libplatform-git
source[0]="${pkgname}::git+https://github.com/xbmc/kodi-platform.git" ;;

jayki commented on 2017-01-08 22:47
CMake Error at CMakeLists.txt:8 (find_package):
By not providing "Findkodi.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "kodi", but
CMake did not find one.

Could not find a package configuration file provided by "kodi" with any of
the following names:

kodiConfig.cmake
kodi-config.cmake

Add the installation prefix of "kodi" to CMAKE_PREFIX_PATH or set
"kodi_DIR" to a directory containing one of the above files.  If "kodi"
provides a separate development package or SDK, be sure it has been
installed.

Bevan commented on 2017-01-09 18:40
@jayki: I'm not sure what the reason for this issue was as I cannot reproduce it. If you set the API level to 99 in the PKGBUILD to get the current git version: there was an outdated dependency. I just fixed this in the PKGBUILD.

If this does not help you, please provide more information on what kodi packages you have installed and if you have changed the API setting in the PKGBUILD.

kodi-platform-git r38.15edaf7-1  (2017-01-09 18:27)
( Неподдерживаемый пакет: Потенциально опасен ! )
==> Отредактировать PKGBUILD ? Да/нет [Y/n] ("A" для отмены)
==> --------------------------------------------------------
==> n

==> зависимости kodi-platform-git:
 - kodi (уже установлен)
 - libplatform-legacy (уже установлен)
 - cmake (уже установлен) [makedepend]
 - git (уже установлен) [makedepend]
==> Продолжить сборку kodi-platform-git ? Да/нет [Y/n]
==> --------------------------------------------------
==> y

==> Сборка и установка пакета
==> Сборка пакета kodi-platform-git r38.15edaf7-1 (Вт янв 10 04:35:33 MSK 2017)
==> Проверка зависимостей для запуска...
==> Проверка зависимостей для сборки...
==> Получение исходных файлов...
  -> Клонирование репозитория 'kodi-platform-git' (git)...
Клонирование в голый репозиторий «/tmp/yaourt-tmp-thenovalive/aur-kodi-platform-git/kodi-platform-git»…
remote: Counting objects: 344, done.
remote: Total 344 (delta 0), reused 0 (delta 0), pack-reused 344
Получение объектов: 100% (344/344), 149.08 KiB | 59.00 KiB/s, готово.
Определение изменений: 100% (165/165), готово.
==> Проверка файлов source с использованием md5sums...
    kodi-platform-git ... Пропущено
==> Распаковка исходных файлов...
  -> Создание рабочей копии репозитория 'kodi-platform' (git)...
Клонирование в «kodi-platform-git»…
готово.
Переключено на новую ветку «makepkg»
==> Запускается pkgver()...
==> Запускается build()...
-- The C compiler identification is GNU 6.2.1
-- The CXX compiler identification is GNU 6.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:8 (find_package):
  By not providing "Findkodi.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "kodi", but
  CMake did not find one.

  Could not find a package configuration file provided by "kodi" with any of
  the following names:

    kodiConfig.cmake
    kodi-config.cmake

  Add the installation prefix of "kodi" to CMAKE_PREFIX_PATH or set
  "kodi_DIR" to a directory containing one of the above files.  If "kodi"
  provides a separate development package or SDK, be sure it has been
  installed.
-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-thenovalive/aur-kodi-platform-git/src/kodi-platform-git/build/CMakeFiles/CMakeOutput.log".
==> ОШИБКА: Произошел сбой в build().
    Прерывание...
==> ОШИБКА: Makepkg не смог собрать kodi-platform-git.
==> Перезапустить сборку kodi-platform-git ? да/Нет [y/N]
==> -----------------------------------------------------
==> n

[thenovalive@hp_pavilion_g6 ~]$

Перед этим установил kodi-git. Установился примерно за часа 2-3, но в итоге запустил и всё ОК!
Помогите с установкой.
TheNovaLive
Помогите с установкой.
Если любишь AUR, будь готов к проблемам и учись их решать самостоятельно ...
Прямо же пишут ….
TheNovaLive
Could not find a package configuration file provided by "kodi" with any of the following names:
kodiConfig.cmake
kodi-config.cmake
Add the installation prefix of "kodi" to CMAKE_PREFIX_PATH or set "kodi_DIR" to a directory containing one of the above files. If "kodi" provides a separate development package or SDK, be sure it has been installed.
А коренная причина похоже в этом (взято из форума kodi)
kodi-config.cmake has been renamed to KodiConfig.cmake a few months ago. But all affected addons have been adapted afaik. They have to use find_package(Kodi) now with upper case K.
Ответственному за пакет (Bevan) на эту проблему уже указали (что, лень было самому зайти сюда ) … читай его ответ от 2017-01-09 18:40 ... и похоже он уже внес измения в PKGBUILD (но что то я это не заметил ...)
И вообще - либо устраняй проблему сам, либо связывайся с автором …
PS … чем больше ставишь левого, тем больше проблем …....
vasek
И вообще - либо устраняй проблему сам, либо связывайся с автором …
вообщем, не нашел у себя этого файла kodi-config.cmake, а также PKGBUILD не помог при установке. Пришлось в АУРе отписываться автору.
Спс за наводку!

P.S.: Прежде чем сюда писать я рою весь гугл. А также АУР комменты читаю, иногда если не понимаю, то тут уже интересуюсь.
Советы бывают разные, даже бывают индивидуальные, поэтому не понятно, возможно и не поможет. Вообщем. всё равно спс!
TheNovaLive, попробовал сейчас установить у себя для проверки ….проблем нет
PS …. правда, kodi-git не ставил …. это не для меня, так как ты пишешь - Установился примерно за часа 2-3
$ yaourt -S kodi-platform-git
.......................
==> Завершена сборка пакета kodi-platform-git r38.15edaf7-1 (Вт янв 10 21:47:39 MSK 2017)
==> Очистка...

==> Продолжить установку kodi-platform-git ? Да/нет [Y/n]
….............................
Установка заняла несколько минут …..... Вот результат ...
$ pacman -Q kodi-platform-git
kodi-platform-git r38.15edaf7-1
Пробуй ….....
PS …. мне это не нужно, так что сразу же и сношу ...
PSS .... забыл сказать, что у меня система 32bit
vasek
попробовал сейчас установить у себя для проверки ….проблем нет …
PS …. правда, kodi-git не ставил
возможно установилось, т.к. Вы не установили сначала "kodi-git", возможно поэтому у Вас без косяков установилось.
Не буду гадать, т.к. у меня всё-таки получилось установить!

отредактировал PKGBUILD и там отредактировал API=99. Далее сохранился и пустил инсталтивароться. Вообщем, всё супер!
Спс за наводки и помощь!
 
Зарегистрироваться или войдите чтобы оставить сообщение.