Xorg 1.18.0 уже в [testing]

Xorg 1.18.0 уже находится в [testing] и содержит следующие изменения:
  • Можно выбирать, что использовать: xf86-input-evdev или xf86-input-libinput
  • xf86-input-aiptek более не поддерживается и будет удалён, как только xorg-1.18.0 попадёт в [extra]
Есть нюанс:
Проприетарные драйвера NVIDIA версию 1.18.0 пока не поддерживают. Заблокировать обновление можно ключом пакмана --ignoregroup=xorg или добавлением 'xorg' в IgnoreGroup в файле pacman.conf.
UPD. Теперь поддерживают!
такие дела.
А меня смутило это …... и, как я понял (может неправильно???), что xf86-input-evdev то же будет удален в дальнейшем?
vasek
А меня смутило это …... и, как я понял (может неправильно???), что xf86-input-evdev то же будет удален в дальнейшем?

Ничего такого вроде не сказано, только о том, что теперь xf86-input-evdev можно оставить как опциональную зависимость или вовсе удалить. Я потестил, удалил, всё нормально. Но откатился на 1.17.4 ибо блоб нвидии нужен.

Кстати просто добавление xorg в группу игнора не помогло, пришлось добавить эти пакеты дополнительно xorg-server-common xorg-server-xwayland
vasek, а что вас смущает? Насколько я помню, раньше xf86-input-evdev вообще не был зависимостью xorg-server и каждый волен был ставить что угодно, будь то драйвер "все в одном" xf86-input-evdev или по отдельности xf86-input-keyboard, xf86-input-mouse, xf86-input-synaptics и т.д.

А вот на счет блоба nvidia удручает.

А так же
upgpkg: xorg-server 1.18.0-3
now all packages are in the xorg group
Это должно починить проблему которую я описал выше.
Обновился, xorg 1.18 и nvidia 340 - всё работает по умолчанию...
то же самое с 304-м блобом
Gnome 2 >> Unity >> KDE 4 >> Openbox >> Awesome >> Xmonad
https://github.com/Haron-Prime
Рапортую - xorg 1.18 nvidia 358 - обновление и перезапуск прошли без замечаний
Да пребудет с нами Сила...!
CPU Intel Core i7 2600K/RAM DDR3 16 Gb/NVidia GForce 580GTX/HDD Seagate SATA3 2 Tb
http://maisvendoo.org
Update: Nvidia drivers are now compatible with xorg-1.18.0 (ABI 20)
In Tux We Trust
А у меня вот после обновления иксы не стартуют (оптимус)
xorg-server 1.18.0-3
nvidia 358.16-2.1
xf86-video-intel 1:2.99.917+478+gdf72bc5-3
xf86-input-evdev 2.10.0-2

Откатиться тоже непонятно как:
loading packages...
warning: downgrading package xorg-server (1.18.0-3 => 1.17.4-1)
resolving dependencies...
looking for conflicting packages...
:: xorg-server and xf86-input-evdev are in conflict. Remove xf86-input-evdev? [y/N] y
:: xorg-server and xf86-video-intel are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-intel? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
 
Зарегистрироваться или войдите чтобы оставить сообщение.