Дефектные обновления.

A.T.W.A.
Да и предложение к администрации: создать и прикрепить ещё две темы:
Дефектные обновления [testing]
Дефектные обновления [AUR]
Иначе тут какая-то каша
А предлагаю еще создать "Дефектные обновления [stable]", а эту закрыть и открепить.
Истина где-то рядом...
R.V., тоже верно.
в консоли

https://t.me/atvva
qt5-base в [extra] обновился до версии 5.8.0-12, которая требует
/usr/lib/libgcc_s.so.1: version `GCC_7.0.0' not found (required by /usr/lib/libQt5Gui.so.5)
gcc-libs-7.1.1-2 , которая пока находится в [testing]

Решения:
1) откатить qt5-base
2) обновить gcc и gcc-libs из [testing]

P.S.
Нет, синхронизация репозиториев тут ни при чём:
https://www.archlinux.org/packages/core/i686/gcc-libs/
https://www.archlinux.org/packages/extra/i686/qt5-base/
Текущие версии пока именно те, что я написал выше, и они несовместимы между собой.
Natrio, а где у тебя такая жалоба выскакивает?
RusWolf
где у тебя такая жалоба выскакивает?
В консоли, вестимо, без неё просто не видно, почему не запустилось :)
При попытке запуска любой программы, использующей qt5, например transmission-qt и VirtuialBox.
Две недели не обновлялся. Сегодня вылезло:
error: could not open file /var/lib/pacman/sync/core.db: Unrecognized archive format
error: could not open file /var/lib/pacman/sync/extra.db: Unrecognized archive format
error: could not open file /var/lib/pacman/sync/community.db: Unrecognized archive format
error: could not open file /var/lib/pacman/sync/multilib.db: Unrecognized archive format

Как говорится, кто виноват и что делать?
Предлагаются только обновления из AURа....
Natrio
При попытке запуска любой программы, использующей qt5, например transmission-qt и VirtuialBox.
Нету таких проблем.

[ruswolf@arch-wolf ~]$ pacman -Qi qt5-base
Название             : qt5-base
Версия               : 5.8.0-12
Описание             : A cross-platform application and UI framework
Архитектура          : x86_64
URL                  : http://qt-project.org/
Лицензии             : GPL3  LGPL3  FDL  custom
Группы               : qt  qt5
Предоставляет        : Нет
Зависит от           : libjpeg-turbo  xcb-util-keysyms  xcb-util-renderutil  libgl  fontconfig  xcb-util-wm
                       libxrender  libxi  sqlite  xcb-util-image  icu  tslib  libinput  libsm  libxkbcommon-x11
                       libproxy  libcups  openssl-1.0
Доп. зависимости     : qt5-svg: to use SVG icon themes [установлено]
                       postgresql-libs: PostgreSQL driver [установлено]
                       libmariadbclient: MariaDB driver [установлено]
                       unixodbc: ODBC driver
                       libfbclient: Firebird/iBase driver [установлено]
                       freetds: MS SQL driver
                       gtk3: GTK platform plugin [установлено]
Требуется            : attica-qt5  avidemux-qt  draftsight  karchive  kcodecs  kconfig  kcoreaddons  kitemmodels
                       kitemviews  kwidgetsaddons  libdbusmenu-qt5  phonon-qt5  polkit-qt5  pyqt5-common
                       qbittorrent  qt5-imageformats  qt5-multimedia  qt5-script  qt5-sensors  qt5-svg
                       qt5-translations  qt5-x11extras  qt5-xmlpatterns  sonnet  virtualbox
Опционально для      : avidemux-cli  pinentry  v4l-utils
Конфликтует с        : qtchooser
Заменяет             : Нет
Установленный размер : 55,17 MiB
Сборщик              : Jan de Groot <jgc@archlinux.org>
Дата сборки          : Ср 17 май 2017 13:17:32
Дата установки       : Чт 25 май 2017 07:53:08
Причина установки    : Установлен как зависимость другого пакета
Установочный скрипт  : No
Проверен             : SHA-256
[ruswolf@arch-wolf ~]$ pacman -Qi gcc-libs-multilib
Название             : gcc-libs-multilib
Версия               : 6.3.1-2
Описание             : Runtime libraries shipped by GCC for multilib
Архитектура          : x86_64
URL                  : http://gcc.gnu.org
Лицензии             : GPL  LGPL  FDL  custom
Группы               : Нет
Предоставляет        : gcc-libs=6.3.1-2
Зависит от           : glibc>=2.25  lib32-gcc-libs=6.3.1-2
Доп. зависимости     : Нет
Требуется            : aspell  augeas  avr-gcc  blas  cdrdao  ceph  clucene  db  draftsight  dvd+rw-tools  dvgrab
                       exempi  exiv2  fcgi  fftw  flac  gc  gcc-multilib  gettext  gmp  gnutls  gptfdisk
                       graphite  groff  hunspell  icu  ilmbase  intel-tbb  js  jsoncpp  ladspa  libcdio  libebml
                       libelf  libfbclient  libgme  libmodplug  libmp4v2  libproxy  libpst  libreoffice-fresh
                       libsidplay  libsigc++  libsoxr  libtiff4  libunrar  libvdpau  libvirt  libvoikko  libvpx
                       libwpd  llvm-libs  mjpegtools  ncurses  netcdf  p7zip  pbzip2  pcre  pcre2  pepper-flash
                       poppler  portaudio  portsmf  protobuf  sbsms  schroedinger  smartmontools  smpeg2  snappy
                       soundtouch  thin-provisioning-tools  tinyxml2  uchardet  unrar  v4l-utils  vamp-plugin-sdk
                       vid.stab  virtualbox  webrtc-audio-processing  wine  x265  zeromq  zita-alsa-pcmi
                       zita-resampler
Опционально для      : Нет
Конфликтует с        : gcc-libs
Заменяет             : Нет
Установленный размер : 78,44 MiB
Сборщик              : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Дата сборки          : Ср 08 мар 2017 18:57:42
Дата установки       : Ср 17 май 2017 08:25:21
Причина установки    : Установлен как зависимость другого пакета
Установочный скрипт  : No
Проверен             : SHA-256

nomad
Как говорится, кто виноват и что делать?
yaourt -Suuyya
Natrio
При попытке запуска любой программы, использующей qt5,
RusWolf
Нету таких проблем.

Потдерждаю, такая проблема имеется, например,
$ smplayer
smplayer: /usr/lib/libgcc_s.so.1: version `GCC_7.0.0' not found (required by /usr/lib/libQt5Gui.so.5)

$ wireshark
wireshark: /usr/lib/libgcc_s.so.1: version `GCC_7.0.0' not found (required by /usr/lib/libQt5Gui.so.5)

Откатываться не стал - таких программ очень мало и есть альтернативы (но, в принципе, пока можно и без них)
PS ... у меня 32 битка, у Natrio вроде то же.

PSS ...
$ pacman -Qi qt5-base | grep Требуется
Требуется : qt5-multimedia qt5-script qt5-svg
$ pactree -r qt5-base
qt5-base
├─qt5-multimedia
│ └─wireshark-qt
├─qt5-script
│ └─smplayer
└─qt5-svg
RusWolf
nomad
Как говорится, кто виноват и что делать?
yaourt -Suuyya
пробовал, конечно, не помогает...
 
Зарегистрироваться или войдите чтобы оставить сообщение.