Дефектные обновления.

vdemin
Моргание было и в `breeze` при 5.5.1-8, после установки 5.5.1-9 ушло.
блин. до меня, как обычно, сразу не доходит)))
Почему то в голове отложилось, что вчерашние обновы не помогли. Дважды перезагрузился. Вроде все ok.
Надо больше спать...
Lupus pilum mutat, non mentem.
Утра всем похоже багнутого.
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
warning: evince: ignoring package upgrade (3.18.2-1 => 3.18.2-2)
warning: firefox: ignoring package upgrade (42.0-3 => 44.0-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.3
https://bugs.archlinux.org/task/47977
Wazzap?
toZen
https://bugs.archlinux.org/task/47977
Wazzap?

Reason for closing: Not a bug
Additional comments about closing: AUR packages are unsupported. Also, search before posting
┌─ tozen {Linux 4.3.3-3-ARCH x86_64} /home/tozen
08:44:14
└─> $ sudo pacman -R yaourt
checking dependencies...

Packages (1) yaourt-1.7-1

Total Removed Size:  0.72 MiB

:: Do you want to remove these packages? [Y/n]
(1/1) removing yaourt                                                                      [####################################################] 100%
┌─ tozen {Linux 4.3.3-3-ARCH x86_64} /home/tozen
08:45:55
└─> $ sudo pacman -Syuu
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
warning: evince: ignoring package upgrade (3.18.2-1 => 3.18.2-2)
warning: firefox: ignoring package upgrade (42.0-3 => 44.0-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: package-query: requires pacman<4.3
┌─ tozen {Linux 4.3.3-3-ARCH x86_64} /home/tozen
08:46:15
└─> $ sudo pacman -R package-query
checking dependencies...

Packages (1) package-query-1.7-1

Total Removed Size:  0.08 MiB

:: Do you want to remove these packages? [Y/n]
(1/1) removing package-query                                                               [####################################################] 100%
┌─ tozen {Linux 4.3.3-3-ARCH x86_64} /home/tozen
08:46:23
└─> $ sudo pacman -Syuu
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
warning: evince: ignoring package upgrade (3.18.2-1 => 3.18.2-2)
warning: firefox: ignoring package upgrade (42.0-3 => 44.0-1)
resolving dependencies...
looking for conflicting packages...

Packages (8) cmake-3.4.3-1  curl-7.47.0-1  expac-5-1  geany-1.26-3  pacman-5.0.0-1  pyalpm-0.8-1  python-setuptools-1:19.6.2-1  tint2-0.12.7-1

Total Download Size:    9.39 MiB
Total Installed Size:  45.41 MiB
Net Upgrade Size:       0.78 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
 curl-7.47.0-1-x86_64                                             796.1 KiB  1131K/s 00:01 [####################################################] 100%
 pacman-5.0.0-1-x86_64                                            730.2 KiB  1272K/s 00:01 [####################################################] 100%
 cmake-3.4.3-1-x86_64                                               4.5 MiB  1259K/s 00:04 [####################################################] 100%
 expac-5-1-x86_64                                                  14.3 KiB  2039K/s 00:00 [####################################################] 100%
 pyalpm-0.8-1-x86_64                                               42.4 KiB  1413K/s 00:00 [####################################################] 100%
 python-setuptools-1:19.6.2-1-any                                 234.5 KiB  1234K/s 00:00 [####################################################] 100%
 geany-1.26-3-x86_64                                                2.9 MiB  1147K/s 00:03 [####################################################] 100%
 tint2-0.12.7-1-x86_64                                            205.8 KiB  1263K/s 00:00 [####################################################] 100%
(8/8) checking keys in keyring                                                             [####################################################] 100%
(8/8) checking package integrity                                                           [####################################################] 100%
(8/8) loading package files                                                                [####################################################] 100%
(8/8) checking for file conflicts                                                          [####################################################] 100%
(8/8) checking available disk space                                                        [####################################################] 100%
(1/8) upgrading curl                                                                       [####################################################] 100%
(2/8) upgrading cmake                                                                      [####################################################] 100%
(3/8) upgrading pacman                                                                     [####################################################] 100%
warning: /etc/pacman.conf installed as /etc/pacman.conf.pacnew
warning: /etc/makepkg.conf installed as /etc/makepkg.conf.pacnew
(4/8) upgrading expac                                                                      [####################################################] 100%
(5/8) upgrading geany                                                                      [####################################################] 100%
(6/8) upgrading pyalpm                                                                     [####################################################] 100%
(7/8) upgrading python-setuptools                                                          [####################################################] 100%
(8/8) upgrading tint2                                                                      [####################################################] 100%
┌─ tozen {Linux 4.3.3-3-ARCH x86_64} /home/tozen
08:46:44
└─> $ sudo pacman -Syu
:: Synchronising package databases...
 core is up to date
 extra is up to date
 community is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
warning: evince: ignoring package upgrade (3.18.2-1 => 3.18.2-2)
warning: firefox: ignoring package upgrade (42.0-3 => 44.0-1)
 there is nothing to do
┌─ tozen {Linux 4.3.3-3-ARCH x86_64} /home/tozen
08:46:49
└─> $ sudo pacman -S yaourt package-query
resolving dependencies...
warning: cannot resolve "pacman<4.3", a dependency of "package-query"
warning: cannot resolve "package-query>=1.4", a dependency of "yaourt"
warning: cannot resolve "pacman<4.3", a dependency of "package-query"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      yaourt  package-query

:: Do you want to skip the above packages for this upgrade? [y/N]
От-туда же.
sirocco
Reason for closing: Not a bug
Additional comments about closing: AUR packages are unsupported. Also, search before posting
А что с аурой? o_O
toZen
sirocco
Reason for closing: Not a bug
Additional comments about closing: AUR packages are unsupported. Also, search before posting
А что с аурой? o_O

О актуальности пакетов в AUR должны заботиться маинтейнеры AUR.

https://aur.archlinux.org/

Отказ от ответственности: AUR packages are user produced content. Any use of the provided files is at your own risk.

В комментах к yaourt, впрочем, давно есть решение.

Если не освоили makepkg, то ждите, когда проснётся Skunnyk

https://afur.archlinux.fr/
toZen, не обязательно было удалять yaourt. Надо было либо подождать пока обновят package-query, либо обновляться с --force и не пользоваться йогуртом пока, опять же, не обновят package-query.

Add. --force - частный случай (всегда пользоваться осторожно).
toZen,
https://www.opennet.ru/opennews/art.shtml?num=43791
Gnome 2 >> Unity >> KDE 4 >> Openbox >> Awesome >> Xmonad
скачать этот PKGBUILD
Удалить там:
'pacman<4.3'
Следом:
makepkg -s
sudo pacman -U package-query-1.7-1-x86_64.pkg.tar.xz (или что в итоге для i686)
я собрал и установил https://aur.archlinux.org/packages/package-query-git/ - всё исправилось, йогурт заработал, обновления установились
в комментах на опеннете об этом писали - https://www.opennet.ru/opennews/art.shtml?num=43791#35

 yaourt -Syyua
:: Обновление баз данных пакетов...
 core                                                                                    122,5 KiB  1408K/s 00:00 [####################################################################] 100%
 extra                                                                                  1763,6 KiB  6,55M/s 00:00 [####################################################################] 100%
 community                                                                                 3,3 MiB  9,34M/s 00:00 [####################################################################] 100%
 multilib                                                                                155,2 KiB  10,8M/s 00:00 [####################################################################] 100%
 archlinuxfr                                                                              11,3 KiB  0,00B/s 00:00 [####################################################################] 100%
  ssx : Нет ответственного
 Другие пакеты: - 114 / 114
Gnome 2 >> Unity >> KDE 4 >> Openbox >> Awesome >> Xmonad
 
Зарегистрируйтесь или войдите что-бы оставить сообщение.