Установка 1С 8.3 на Archlinux

Может кому пригодится.
Рецепт установки 1С 8.3 на Archlinux.
Качаем линукс версию 1С (если кому надо могу скинуть файлы инсталяции, пишите в skype). Так как у меня на работе стоит 8.3.4.-482 PKGBUILD писал для нее.

Далее берем PKGBUILD


pkgname=1C_Enterprise83
pkgver=8.3.4
pkgrel=482
pkgdesc="1C 8.3 for Linux"
license=('custom')
arch=($CARCH)
options=('!strip')
depends=('webkitgtk' 'imagemagick<=6.7.7.6' 'libgsf' 'unixodbc' 'webkitgtk2')
makedepends=('pkgextract')
url="www.1c.ru"
source=($pkgname-client-$pkgver-$pkgrel.$arch.rpm
$pkgname-client-nls-$pkgver-$pkgrel.$arch.rpm
$pkgname-common-$pkgver-$pkgrel.$arch.rpm
$pkgname-common-nls-$pkgver-$pkgrel.$arch.rpm
$pkgname-server-$pkgver-$pkgrel.$arch.rpm
$pkgname-server-nls-$pkgver-$pkgrel.$arch.rpm
$pkgname-thin-client-$pkgver-$pkgrel.$arch.rpm
$pkgname-thin-client-nls-$pkgver-$pkgrel.$arch.rpm
$pkgname-ws-$pkgver-$pkgrel.$arch.rpm
$pkgname-ws-nls-$pkgver-$pkgrel.$arch.rpm
)
md5sums=('62b3d5f3123bc01b0f83841063df5eb1'
         '5fa7f03d11aca121fdc6037c273f45a8'
         'b4f71a62b13d113e09dd22d2af3d0802'
         '60d8ef23d852cb953e252653a689b8c1'
        '60e2b1aaaaaa14b1bf2fd23ea2b8a9a0'
       'b39da8ed9f0692e31f6af6e64abecdc0'
         '9a6a201f2e4a5fe3dc8d74bed6a7fd51'
         '6ca9e700f1abb07810950acfb0f6e4ab'
         'af625b7777c1023475a19a5d005d6fb8'
         'bc9f68858e1f03cf7df8b6263ddd1829')

package(){
   cd $pkgdir
   cp -r $startdir/src/usr $pkgdir
   cp -r $startdir/src/etc $pkgdir
   cp -r $startdir/src/opt $pkgdir
}
Для того чтобы 1С работала в тонком клиенте (а так же в новом интерфейсе "ТАКСИ") необходима версия Imagemagick - 6.7.7.6 (возможно работает и на более свежих, я проверял на той что в репах imagemagick-6.9.0.2-1 - ошибка загрузки компоненты libwand.so - попытки явно указать на библиотеку с помощью симлинков не получилось..не стал разбиратся поставил ту что рабоает. По сему выкладываю PKGBUILD для imagemagick:


# $Id: PKGBUILD 228251 2014-12-31 19:42:47Z eric $
# Maintainer: Eric Bélanger <eric@archlinux.org>

pkgbase=imagemagick
pkgname=('imagemagick' 'imagemagick-doc')
pkgver=6.7.7.6
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.imagemagick.org/"
license=('custom')
makedepends=('libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'ghostscript'
             'openexr' 'libwmf' 'librsvg' 'libxml2' 'liblqr' 'openjpeg2'
             'opencl-headers' 'libcl' 'libwebp' 'subversion')
#source=(http://www.imagemagick.org/download/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz{,.asc}
source=(ftp://ftp.sunet.se/pub/multimedia/graphics/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.xz)
sha1sums=('93d41c4837a04aba2f03749166af57b364e747f9')

prepare() {
  cd ImageMagick-${pkgver%.*}-${pkgver##*.}
  sed '/AC_PATH_XTRA/d' -i configure.ac
  autoreconf --force --install
}

build() {
  cd ImageMagick-${pkgver%.*}-${pkgver##*.}
  [[ $CARCH = "i686" ]] && EXTRAOPTS="--with-gcc-arch=i686"
  [[ $CARCH = "x86_64" ]] && EXTRAOPTS="--with-gcc-arch=x86-64"

  ./configure --prefix=/usr --sysconfdir=/etc --with-modules \
    --enable-hdri --with-wmf --with-openexr --with-xml --with-lcms2 \
    --with-webp --with-gslib --with-gs-font-dir=/usr/share/fonts/Type1 \
    --with-perl --with-perl-options="INSTALLDIRS=vendor" --with-lqr --with-rsvg \
    --enable-opencl --with-openjp2 --without-gvc --without-djvu --without-autotrace \
    --without-jbig --without-fpx --without-dps --without-fftw $EXTRAOPTS
  make
}

check() {
  cd ImageMagick-${pkgver%.*}-${pkgver##*.}
#  make check
}

package_imagemagick() {
  pkgdesc="An image viewing/manipulation program"
  depends=('perl' 'libltdl' 'lcms2' 'libxt' 'fontconfig' 'libxext' 'liblqr' 'libcl')
  optdepends=('imagemagick-doc: for additional information'
              'ghostscript: for Ghostscript support'
              'openexr: for OpenEXR support'
	      'openjpeg2: for JP2 support'
              'libwmf: for WMF support'
              'librsvg: for SVG support'
              'libxml2: for XML support'
              'libpng: for PNG support'
	      'libwebp: for WEBP support')
  backup=("etc/ImageMagick-${pkgver%%.*}/coder.xml"
          "etc/ImageMagick-${pkgver%%.*}/colors.xml"
          "etc/ImageMagick-${pkgver%%.*}/delegates.xml"
          "etc/ImageMagick-${pkgver%%.*}/log.xml"
          "etc/ImageMagick-${pkgver%%.*}/magic.xml"
          "etc/ImageMagick-${pkgver%%.*}/mime.xml"
          "etc/ImageMagick-${pkgver%%.*}/policy.xml"
          "etc/ImageMagick-${pkgver%%.*}/quantization-table.xml"
          "etc/ImageMagick-${pkgver%%.*}/thresholds.xml"
          "etc/ImageMagick-${pkgver%%.*}/type.xml"
          "etc/ImageMagick-${pkgver%%.*}/type-dejavu.xml"
          "etc/ImageMagick-${pkgver%%.*}/type-ghostscript.xml"
          "etc/ImageMagick-${pkgver%%.*}/type-windows.xml")
  options=('!docs' 'libtool' '!emptydirs')

  cd ImageMagick-${pkgver%.*}-${pkgver##*.}
  make -j1 DESTDIR="${pkgdir}" install
  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick/LICENSE"
  install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick/NOTICE"

#Cleaning
  rm -f "${pkgdir}"/usr/lib/*.la
}

package_imagemagick-doc() {
  pkgdesc="The ImageMagick documentation (utilities manuals and libraries API)"

  cd ImageMagick-${pkgver%.*}-${pkgver##*.}
  make DESTDIR="${pkgdir}" install-data-html
  install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/imagemagick-doc/LICENSE"
  install -Dm644 NOTICE "${pkgdir}/usr/share/licenses/imagemagick-doc/NOTICE"
}

То есть последовательность такова:

pacman -S webkitgtk  libgsf unixodbc webkitgtk2

После чего ставим imagemagick нужной версии.

Ставим 1С.

Для того чтобы imagemagick не обновился ставим заморозку на обновления

в /etc/pacman.conf:


IgnorePkg   = imagemagick

ну и для того чтобы 1С прочитала ключик (если кто нашел способ обойти защиту 1С на Linux версии сообщите)
создаем каталог и создаем файлик nethasp.ini:

sudo mkdir /opt/1C/v8.3/x86_64/conf/

sudo vim /opt/1C/v8.3/x86_64/conf/nethasp.ini

содержимое файлика у меня такое:


[NH_COMMON]
NH_TCPIP = Enabled
[NH_TCPIP]
NH_SERVER_ADDR = 168.192.0.58 , 192.168.100.2

собственно все работает:

Конфигуратор:


Режим предприятия:
картинки или под спойлер или на itmages.ru
Исправил
Не будете против, если перенесу в блоги? Мне кажется там для этой темы будет более подходящее место.
vadik
Не будете против, если перенесу в блоги? Мне кажется там для этой темы будет более подходящее место.

Нет проблем, переносите.
по поводу патча, крутится тут в сети какой то unipatch, всякие тролли с пеной у рта кричат, что он рабочий. Но у меня запустить так и не удалось.
Народ,. может кто из вас разберется?
https://cloud.mail.ru/public/1910296b6782/UniPatch_Win-Lin.zip
Говорят еще, что из под винды backbas.so патчится на ура, но опять же, мне повторить такой фокус не удалось
hlistalin
по поводу патча, крутится тут в сети какой то unipatch, всякие тролли с пеной у рта кричат, что он рабочий. Но у меня запустить так и не удалось.
Народ,. может кто из вас разберется?
https://cloud.mail.ru/public/1910296b6782/UniPatch_Win-Lin.zip

Я патчам не доверяю, по сему на виртуалочке разверну завтра, посмотрю..
hlistalin
Говорят еще, что из под винды backbas.so патчится на ура, но опять же, мне повторить такой фокус не удалось

Сказки говорят..проверял файлы разной структуры..так что как оно патчится будет не знаю.
hlistalin
по поводу патча, крутится тут в сети какой то unipatch, всякие тролли с пеной у рта кричат, что он рабочий. Но у меня запустить так и не удалось.
Народ,. может кто из вас разберется?
https://cloud.mail.ru/public/1910296b6782/UniPatch_Win-Lin.zip

Не понятный файл для Linux - похоже не рабочий, потому что запустить его у меня тоже не вышло...он не исполняемый как его запустить не понятно. Гугление не помогло
 
Зарегистрируйтесь или войдите что-бы оставить сообщение.